aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/cracklib/APKBUILD18
-rw-r--r--main/cracklib/cracklib-nls.patch12
2 files changed, 27 insertions, 3 deletions
diff --git a/main/cracklib/APKBUILD b/main/cracklib/APKBUILD
index f7fda7960c..c82e9038f3 100644
--- a/main/cracklib/APKBUILD
+++ b/main/cracklib/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=cracklib
-pkgver=2.8.13
-pkgrel=1
+pkgver=2.8.16
+pkgrel=0
pkgdesc="A library used to enforce strong passwords"
url="http://sourceforge.net/projects/cracklib"
license="GPL"
@@ -11,7 +11,14 @@ makedepends=""
install=
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ cracklib-nls.patch
"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 -i "$srcdir"/cracklib-nls.patch
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -24,8 +31,13 @@ build() {
--disable-nls \
--with-default-dict
make -j1 all || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
make -j1 DESTDIR="$pkgdir" install
}
-md5sums="5beb4c6b3c31c83fc98c4c225b25cd94 cracklib-2.8.13.tar.gz"
+md5sums="3bfb22db8fcffd019463ee415a1b25b7 cracklib-2.8.16.tar.gz
+239b1b7b59bee4dee7577aa9df18ba46 cracklib-nls.patch"
diff --git a/main/cracklib/cracklib-nls.patch b/main/cracklib/cracklib-nls.patch
new file mode 100644
index 0000000000..3792b741c4
--- /dev/null
+++ b/main/cracklib/cracklib-nls.patch
@@ -0,0 +1,12 @@
+--- ./util/check.c.orig
++++ ./util/check.c
+@@ -22,7 +22,9 @@
+ int i;
+
+ setlocale(LC_ALL, "");
++#if defined(ENABLE_NLS)
+ textdomain(PACKAGE);
++#endif
+
+ while (fgets(buf, sizeof(buf), stdin) != NULL) {
+ while (((i = strlen(buf)) > 0) && (i > 0)) {