aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/firefox-esr/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index b5d4253d7a..6488145cc4 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -105,6 +105,9 @@ build() {
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"
+ local extra_flags=""
+ [ "$CARCH" = "s390x" ] && extra_flags="--disable-startupcache"
+
../configure \
--prefix=/usr \
\
@@ -141,7 +144,7 @@ build() {
--with-system-pixman \
--with-system-png \
--with-system-zlib \
- || return 1
+ $extra_flags
make || return 1
# paxmark outside fakeroot