aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/icu/APKBUILD18
-rw-r--r--main/icu/icu-ccache.patch11
-rw-r--r--main/open-vm-tools/APKBUILD2
-rw-r--r--main/php/APKBUILD2
-rw-r--r--main/webkit/APKBUILD2
5 files changed, 13 insertions, 22 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index 837ff25dab..64b09c0964 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -1,13 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=icu
-pkgver=4.6.1
+pkgver=4.8
# convert x.y.z to x_y_z
_x=${pkgver%%.*}
-_ver=${pkgver%.*} # _ver=x.y
-_y=${_ver#*.}
-_z=${pkgver##*.}
-_ver=${_x}_${_y}_${_z}
+_y=${pkgver#$_x.}
+_y=${_y%%.*}
+_z=${pkgver#*.*.}
+if [ "$_z" = "$pkgver" ]; then
+ _ver=${_x}_${_y}
+else
+ _ver=${_x}_${_y}_${_z}
+fi
pkgrel=0
pkgdesc="International Components for Unicode library"
@@ -18,7 +22,6 @@ subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends=
source="http://download.icu-project.org/files/icu4c/${pkgver}/${pkgname}4c-$_ver-src.tgz
- icu-ccache.patch
"
_builddir="$srcdir"/icu/source
@@ -57,5 +60,4 @@ package() {
install -Dm644 "$srcdir"/icu/license.html \
"$pkgdir"/usr/share/licenses/icu/license.html
}
-md5sums="da64675d85f0c2191cef93a8cb5eea88 icu4c-4_6_1-src.tgz
-e729eb08687b042e40df572932cbf9ce icu-ccache.patch"
+md5sums="e78194c49d7fd8131353aa180d11b789 icu4c-4_8-src.tgz"
diff --git a/main/icu/icu-ccache.patch b/main/icu/icu-ccache.patch
deleted file mode 100644
index 214b9093c6..0000000000
--- a/main/icu/icu-ccache.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tools/icuinfo/Makefile.in.orig
-+++ ./tools/icuinfo/Makefile.in
-@@ -36,7 +36,7 @@
-
- ICUINFO_OPTS=-i ../../data/out/build/$(ICUDATA_PLATFORM_NAME)
-
--CPPFLAGS+= -DU_PLATFORM=\"@platform@\" -DU_BUILD=\"@build@\" -DU_HOST=\"@host@\" -DU_CC=\"@CC@\" -DU_CXX=\"@CXX@\"
-+CPPFLAGS+= -DU_PLATFORM=\"@platform@\" -DU_BUILD=\"@build@\" -DU_HOST=\"@host@\" '-DU_CC="@CC@"' '-DU_CXX="@CXX@"'
- # -DENABLE_RELEASE=@ENABLE_RELEASE@ -DENABLE_DEBUG=@ENABLE_DEBUG@ "
-
-
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
index 87edf01454..99c0cac4ec 100644
--- a/main/open-vm-tools/APKBUILD
+++ b/main/open-vm-tools/APKBUILD
@@ -2,7 +2,7 @@
pkgname=open-vm-tools
pkgver=2011.03.28
_pkgsubver=387002
-pkgrel=2
+pkgrel=3
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="http://open-vm-tools.sourceforge.net/"
arch="all"
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index 64b13b7417..032d5639dd 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php
pkgver=5.3.6
_suhosinver=5.3.6-0.9.10
-pkgrel=10
+pkgrel=11
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
arch="all"
diff --git a/main/webkit/APKBUILD b/main/webkit/APKBUILD
index d4124f3f4b..19d6f8105b 100644
--- a/main/webkit/APKBUILD
+++ b/main/webkit/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=webkit
pkgver=1.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="portable web rendering engine WebKit for GTK+"
url="http://webkitgtk.org/"
arch="all"