aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-aiohttp-gns3/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-aiohttp-gns3/APKBUILD b/community/py3-aiohttp-gns3/APKBUILD
new file mode 100644
index 0000000000..dc3180c176
--- /dev/null
+++ b/community/py3-aiohttp-gns3/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-aiohttp-gns3
+_pkgname=aiohttp
+pkgver=2.3.10
+pkgrel=0
+pkgdesc="HTTP client/server for asyncio - GNS3 compatible version"
+url="https://pypi.python.org/pypi/aiohttp"
+arch="all"
+license="Apache-2.0"
+depends="python3 py3-async-timeout py3-chardet py3-multidict py3-yarl
+ py3-idna-ssl py3-attrs"
+makedepends="python3-dev py3-setuptools cython-dev"
+conflicts="py3-aiohttp"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha512sums="e4ea725bbd3d7d749f2ec21eea1ff9f5c836fbeaa17ad72f77e378c69b008448e57503175bee6adff86110f65edc915cb6368df3011d1d9d61cf47718b086be0 py3-aiohttp-gns3-2.3.10.tar.gz"