aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/spice/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/main/spice/APKBUILD b/main/spice/APKBUILD
index 6bc85302b6..830f972cbe 100644
--- a/main/spice/APKBUILD
+++ b/main/spice/APKBUILD
@@ -12,14 +12,13 @@ depends_dev="spice-protocol pixman-dev celt051-dev libressl-dev libxinerama-dev"
makedepends="$depends_dev alsa-lib-dev libjpeg-turbo-dev libxrandr-dev
cyrus-sasl-dev libxfixes-dev python2-dev bash cegui06-dev py-parsing
py-six glib-dev opus-dev"
-install=""
subpackages="$pkgname-dev $pkgname-server"
source="http://www.spice-space.org/download/releases/$pkgname-$pkgver.tar.bz2
CVE-2016-9577.patch
CVE-2016-9578-1.patch
CVE-2016-9578-2.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 0.12.8-r3:
@@ -39,15 +38,19 @@ build() {
--enable-gui \
--enable-client \
--disable-smartcard \
- --enable-opus \
- || return 1
- make -C spice-common WARN_CFLAGS='' || return 1
- make WARN_CFLAGS='' || return 1
+ --enable-opus
+ make -C spice-common WARN_CFLAGS=''
+ make WARN_CFLAGS=''
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
server() {