aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/yarn/APKBUILD13
-rw-r--r--testing/yarn/remove-support-for-legacy-nodejs.patch23
2 files changed, 33 insertions, 3 deletions
diff --git a/testing/yarn/APKBUILD b/testing/yarn/APKBUILD
index 5dbc2db16f..5564c76267 100644
--- a/testing/yarn/APKBUILD
+++ b/testing/yarn/APKBUILD
@@ -10,6 +10,7 @@ license="BSD-2"
depends="nodejs"
source="https://yarnpkg.com/downloads/$pkgver/$pkgname-v$pkgver.tar.gz
add-apk-install-method.patch"
+ remove-support-for-legacy-nodejs.patch"
builddir="$srcdir/dist"
prepare() {
@@ -20,6 +21,9 @@ prepare() {
# These tests runs only on Ubuntu, so delete them.
rm -r end_to_end_tests
+ # Remove support for legacy nodejs.
+ rm -r lib-legacy
+
# Remove some unneeded files.
# Node does not load *.min.js files, so these are useless for us.
# We respect licenses, but really don't wanna waste disk space (~1 MiB)
@@ -48,8 +52,11 @@ package() {
ln -s /$destdir/bin/yarn "$pkgdir"/usr/bin/yarnpkg
}
md5sums="12df75bdb018b0412580ccc5ffee5c6e yarn-v0.20.0.tar.gz
-4c15d156298c24d76ca16961b55ec2c0 add-apk-install-method.patch"
+4c15d156298c24d76ca16961b55ec2c0 add-apk-install-method.patch
+3f3440fa9a2f50df2ee083f5269e31e5 remove-support-for-legacy-nodejs.patch"
sha256sums="4622f3c7a2fdf0dac3ef38b49eb636b813734e06a5a688fb2545df857792ebe3 yarn-v0.20.0.tar.gz
-fd2b4c0d38f15a9a0f28e4619ceb3361d0bc3ac600ce7886476a62bef3a63e37 add-apk-install-method.patch"
+fd2b4c0d38f15a9a0f28e4619ceb3361d0bc3ac600ce7886476a62bef3a63e37 add-apk-install-method.patch
+084958810b3f7a81bf6c6a9d7edae563722f8006134d28e82494892a795680d9 remove-support-for-legacy-nodejs.patch"
sha512sums="9f1a63b7e41a52059b3f30c029b4c249e44c24a7a48dc55bec2806009fcd725b39205fd8b4c292bc19fa968b0694d692616610cf038de2c50d2f91dbb7ab7bb8 yarn-v0.20.0.tar.gz
-9dcf2496d2c9f8a36db915cb6433aad449abbcc2503855c7b2afe9b3cce024f76da0ab4daf44bc42df97595748c7bea38900d91a4d28e344ffc83eec8a212a9f add-apk-install-method.patch"
+9dcf2496d2c9f8a36db915cb6433aad449abbcc2503855c7b2afe9b3cce024f76da0ab4daf44bc42df97595748c7bea38900d91a4d28e344ffc83eec8a212a9f add-apk-install-method.patch
+d62bb07f1361039018ed0a3a3fbff5958c51430e21c356b265768eb494fc74c3c6977e4fdd4629d4914f9afd17864b4a13c8fcda9c92ba9c630badd2f9cea7ad remove-support-for-legacy-nodejs.patch"
diff --git a/testing/yarn/remove-support-for-legacy-nodejs.patch b/testing/yarn/remove-support-for-legacy-nodejs.patch
new file mode 100644
index 0000000000..dbb7d9d71d
--- /dev/null
+++ b/testing/yarn/remove-support-for-legacy-nodejs.patch
@@ -0,0 +1,23 @@
+diff -urp dist/bin/yarn.js patched/bin/yarn.js
+--- dist/bin/yarn.js 2017-01-30 14:11:29.000000000 +0000
++++ patched/bin/yarn.js 2017-02-01 02:41:32.000000000 +0000
+@@ -16,17 +16,14 @@ var _err;
+ if (semver.satisfies(ver, '>=5.0.0')) {
+ possibles.push('../updates/current/lib/cli/index.js');
+ possibles.push('../lib/cli/index.js');
+-} else if (semver.satisfies(ver, '>=4.0.0')) {
+- possibles.push('../updates/current/lib-legacy/cli/index.js');
+- possibles.push('../lib-legacy/cli/index.js');
+ } else {
+- console.log(require('chalk').red('Node version ' + ver + ' is not supported, please use Node.js 4.0 or higher.'));
++ console.log(require('chalk').red('Node version ' + ver + ' is not supported, please use Node.js 5.0 or higher.'));
+ process.exit(1);
+ }
+
+ // ensure cache directory exists
+ var mkdirp = require('mkdirp');
+-var constants = require('../lib-legacy/constants');
++var constants = require('../lib/constants');
+ mkdirp.sync(constants.MODULE_CACHE_DIRECTORY);
+
+ // init roadrunner