aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ocamlbuild/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
index ee4e7e69b3..2c0c358758 100644
--- a/community/ocamlbuild/APKBUILD
+++ b/community/ocamlbuild/APKBUILD
@@ -7,6 +7,7 @@ pkgdesc="Generic build tool with built-in rules for building OCaml library and p
url="https://github.com/ocaml/ocamlbuild"
arch="all !x86 !armhf !s390x" #ocaml not avail on excluded platforms
license="LGPL-2.0-or-later-WITH-linking-exception"
+checkdepends="ocaml-compiler-libs ocaml-findlib"
makedepends="ocaml"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/$pkgname/archive/$pkgver.tar.gz"
@@ -21,6 +22,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"