aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/x265/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/x265/APKBUILD b/main/x265/APKBUILD
index d4a574c350..abdf5f0380 100644
--- a/main/x265/APKBUILD
+++ b/main/x265/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="GPL"
depends=""
depends_dev=""
-makedepends="$depends_dev yasm cmake"
+makedepends="$depends_dev cmake yasm"
install=""
subpackages="$pkgname-dev"
source="http://ftp.videolan.org/pub/videolan/x265/x265_${pkgver}.tar.gz
@@ -29,7 +29,12 @@ prepare() {
build() {
cd "$_builddir"/build/linux
- cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr ../../source
+ local CMAKE_OPS="-DCMAKE_INSTALL_PREFIX=/usr"
+ # has textrel on x86 so we disable asm
+ if [ "$CARCH" = x86 ] ; then
+ CMAKE_OPS="$CMAKE_OPS -DENABLE_ASSEMBLY=OFF"
+ fi
+ cmake -G "Unix Makefiles" $CMAKE_OPS ../../source
}
package() {