aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/acl/APKBUILD10
-rw-r--r--main/acl/busybox-gzip.patch26
2 files changed, 32 insertions, 4 deletions
diff --git a/main/acl/APKBUILD b/main/acl/APKBUILD
index 9aa00802f2..a159eeac24 100644
--- a/main/acl/APKBUILD
+++ b/main/acl/APKBUILD
@@ -1,19 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=acl
pkgver=2.2.52
-pkgrel=4
+pkgrel=5
pkgdesc="Access control list utilities"
url="https://savannah.nongnu.org/projects/acl"
arch="all"
license="LGPL-2.1-or-later AND GPL-2.0-or-later"
depends=""
-makedepends_build="gzip"
+makedepends_build=""
makedepends_host="attr-dev"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-dev $pkgname-doc libacl"
# depends on order of nftw, and requires test machine to have ACLs enabled on FS
options="!check"
-source="http://download.savannah.nongnu.org/releases/acl/acl-$pkgver.src.tar.gz"
+source="http://download.savannah.nongnu.org/releases/acl/acl-$pkgver.src.tar.gz
+ busybox-gzip.patch"
prepare() {
cd "$builddir"
@@ -55,4 +56,5 @@ libacl() {
mv "$pkgdir"/lib/libacl.so.* "$subpkgdir"/lib/
}
-sha512sums="59973199d371cd0b2368e95bc829a1b47f04e808a174fefba4c6854e766158bd19a71d9dbcc8d6fdc1573a1f971cdda39c453f7fa243bce02c1ab97c6e7c72e7 acl-2.2.52.src.tar.gz"
+sha512sums="59973199d371cd0b2368e95bc829a1b47f04e808a174fefba4c6854e766158bd19a71d9dbcc8d6fdc1573a1f971cdda39c453f7fa243bce02c1ab97c6e7c72e7 acl-2.2.52.src.tar.gz
+00a929f0079714b38956f0680d33a2b288ecfc97784192f91d8ce738f7e590201b2ca7e905dff7b853d724f6c4803710f6b37fc721eab88d29abbfca47691291 busybox-gzip.patch"
diff --git a/main/acl/busybox-gzip.patch b/main/acl/busybox-gzip.patch
new file mode 100644
index 0000000000..e443fc495c
--- /dev/null
+++ b/main/acl/busybox-gzip.patch
@@ -0,0 +1,26 @@
+diff --git a/doc/Makefile b/doc/Makefile
+index a08e403..d739781 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -28,7 +28,7 @@ default: CHANGES.gz
+ include $(BUILDRULES)
+
+ CHANGES.gz:
+- $(ZIP) --best -c < CHANGES > $@
++ $(ZIP) -c < CHANGES > $@
+
+ install: default
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+diff --git a/include/buildmacros b/include/buildmacros
+index 9e81bb8..b33e148 100644
+--- a/include/buildmacros
++++ b/include/buildmacros
+@@ -139,7 +139,7 @@ endif
+ MAN_MAKERULE = \
+ @for f in *.[12345678] ""; do \
+ if test ! -z "$$f"; then \
+- $(ZIP) --best -c < $$f > $$f.gz; \
++ $(ZIP) -c < $$f > $$f.gz; \
+ fi; \
+ done
+