aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/nebula/APKBUILD (renamed from unmaintained/nebula/APKBUILD)12
-rw-r--r--testing/nebula/musl-fixes.patch32
2 files changed, 41 insertions, 3 deletions
diff --git a/unmaintained/nebula/APKBUILD b/testing/nebula/APKBUILD
index 4dd3e5c228..9e66f7dfa6 100644
--- a/unmaintained/nebula/APKBUILD
+++ b/testing/nebula/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=nebula
pkgver=0.2.3
-pkgrel=0
+pkgrel=1
pkgdesc="An Intrusion Signature Generator"
url="http://nebula.carnivore.it/"
arch="all"
@@ -12,7 +12,8 @@ depends_dev=""
makedepends="zlib-dev"
install=""
subpackages="$pkgname-client"
-source="http://downloads.sourceforge.net/nebula/$pkgname-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/nebula/$pkgname-$pkgver.tar.gz
+ musl-fixes.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -48,4 +49,9 @@ client() {
mv "$pkgdir"/usr/bin/"$pkgname"client "$subpkgdir"/usr/bin/
}
-md5sums="06eabd66634e7969203465fb94900f18 nebula-0.2.3.tar.gz"
+md5sums="06eabd66634e7969203465fb94900f18 nebula-0.2.3.tar.gz
+393c6ba03578214aa720cd8a703d8b1b musl-fixes.patch"
+sha256sums="6d90fe1c5c1d81045134485e8ee4e888e9fce5d4323a2b6b321bf8a9765fc856 nebula-0.2.3.tar.gz
+e35212e0b65711fd9ead733e15fe76c79a15de7ac7c417a4c26df400df6f590b musl-fixes.patch"
+sha512sums="9202be7ca3c78e7dadf559180a3a9a331ed0ddd4b04aa16ac0c65856f513e600e4e04b7908d4be412360c3fc7e91a286723be1151c74333f0111a4307e323023 nebula-0.2.3.tar.gz
+790c3682e3a32da44e83bcfc44c1483b866d526efdfee6522a42878a9ac3aab65341515c9a080e22e44f5e9daff3b4c55c3e53da6ee68e6580df74850e3b44dd musl-fixes.patch"
diff --git a/testing/nebula/musl-fixes.patch b/testing/nebula/musl-fixes.patch
new file mode 100644
index 0000000000..a23d8a1a0f
--- /dev/null
+++ b/testing/nebula/musl-fixes.patch
@@ -0,0 +1,32 @@
+--- nebula-0.2.3/src/hash.h
++++ nebula-0.2.3/src/hash.h
+@@ -24,7 +24,7 @@
+ #if HAVE_CONFIG_H
+ # include <config.h>
+ #endif
+-
++#include "sys/types.h"
+
+ struct cluster;
+
+--- nebula-0.2.3/src/spamsum.h
++++ nebula-0.2.3/src/spamsum.h
+@@ -24,7 +24,7 @@
+ #if HAVE_CONFIG_H
+ # include <config.h>
+ #endif
+-
++#include "sys/types.h"
+
+ char *spamsum(const u_char *in, size_t length, uint32_t bsize);
+ uint32_t spamsum_match(const char *str1, const char *str2);
+--- nebula-0.2.3/src/trie.h
++++ nebula-0.2.3/src/trie.h
+@@ -24,6 +24,7 @@
+ #if HAVE_CONFIG_H
+ # include <config.h>
+ #endif
++#include "sys/types.h"
+
+ struct trie_node;
+ typedef struct trie_node *trie;