aboutsummaryrefslogtreecommitdiffstats
path: root/community/babl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/babl/APKBUILD')
-rw-r--r--community/babl/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/babl/APKBUILD b/community/babl/APKBUILD
new file mode 100644
index 0000000000..b850f692b8
--- /dev/null
+++ b/community/babl/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=babl
+pkgver=0.1.30
+pkgrel=0
+pkgdesc="Dynamic, any to any, pixel format conversion library"
+url="http://gegl.org/babl/"
+arch="all"
+license="LGPL3+"
+subpackages="$pkgname-dev"
+source="http://ftp.gimp.org/pub/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="391182786312140fe3fa8b4b8448df2829230ef6a1d9957d8bb729c464e94f5b1300ad761d04f51b3d777c4de9fb462dd0391c3f0c2daa53e9c53bf697e58dca babl-0.1.30.tar.bz2"