aboutsummaryrefslogtreecommitdiffstats
path: root/community/libhtp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libhtp/APKBUILD')
-rw-r--r--community/libhtp/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/libhtp/APKBUILD b/community/libhtp/APKBUILD
new file mode 100644
index 0000000000..173062e21d
--- /dev/null
+++ b/community/libhtp/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Steve McMaster <code@mcmaster.io>
+# Maintainer: Steve McMaster <code@mcmaster.io>
+pkgname=libhtp
+pkgver=0.5.25
+pkgrel=0
+pkgdesc="HTTP normalizer and parser library"
+url="https://github.com/OISF/libhtp"
+arch="all"
+license="BSD"
+# the zlib-dev dependency is not listed in the .pc file but the headers
+# needs zlib.h, so we add explicit to depends_dev
+depends_dev="zlib-dev"
+makedepends="$depends_dev automake autoconf libtool"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/OISF/libhtp/archive/$pkgver.tar.gz
+"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ autoreconf -vif
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+sha512sums="130e4af4c7b3d949472eb355334cb719d6792b57be41b847ee1aaaaf18aaf678dbef8137adc1567ec09bcef5ca6eb45d113776503173a7225e68a708c750ee21 libhtp-0.5.25.tar.gz"