aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxspf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxspf/APKBUILD')
-rw-r--r--community/libxspf/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/libxspf/APKBUILD b/community/libxspf/APKBUILD
new file mode 100644
index 0000000000..3756b2294c
--- /dev/null
+++ b/community/libxspf/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=libxspf
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Brings XSPF playlist reading and writing support to C++ application"
+url="http://libspiff.sourceforge.net"
+arch="all"
+license="BSD"
+makedepends="expat-dev uriparser-dev cpptest-dev"
+subpackages="$pkgname-dev"
+source="http://downloads.xiph.org/releases/xspf/libxspf-1.2.0.tar.gz
+ add-missing-include.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="ff1816e782e8967c5d672acff268be33f21c2add86a057da6cee085ca87e9a985dc1ea07e94f046e95a18afaf55b014d089883cb9db0532f5ec0697ca4e806fb libxspf-1.2.0.tar.gz
+f511bf02791e348492f45901454ec8db6ac2c3f5d1707aff8aa3471853870eed89767564749412e13c0542585057da48c453412bd533418ecc1e2b2a103cc8d6 add-missing-include.patch"