aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-fun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-fun/APKBUILD')
-rw-r--r--community/lua-fun/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/lua-fun/APKBUILD b/community/lua-fun/APKBUILD
index 6865f0c2cf..041bae69ca 100644
--- a/community/lua-fun/APKBUILD
+++ b/community/lua-fun/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Michael Zuo <muh.muhten@gmail.com>
# Maintainer: Michael Zuo <muh.muhten@gmail.com>
pkgname=lua-fun
+_rockname=fun
_pkgname=luafun
pkgver=0.1.3
-pkgrel=5
+pkgrel=6
pkgdesc="Functional programming library"
url="http://rtsisyk.github.io/luafun/"
arch="noarch"
@@ -44,9 +45,13 @@ _subpackage() {
pkgdesc="$pkgdesc for Lua $lver"
depends="lua$lver"
install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
+ local rockdir="$subpkgdir/usr/lib/luarocks/rocks-$lver/$_rockname/$pkgver-1"
cd "$builddir"
install -m 644 -D fun.lua "$subpkgdir"/usr/share/lua/$lver/fun.lua
+
+ mkdir -p "$rockdir"
+ echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
md5sums="ab774af3d0dea06656039e5fc3ee86ad lua-fun-0.1.3.tar.gz"