aboutsummaryrefslogtreecommitdiffstats
path: root/community/mumble/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mumble/APKBUILD')
-rw-r--r--community/mumble/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/community/mumble/APKBUILD b/community/mumble/APKBUILD
index 7933dcd3ef..edef92689e 100644
--- a/community/mumble/APKBUILD
+++ b/community/mumble/APKBUILD
@@ -3,11 +3,11 @@
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=mumble
pkgver=1.2.19
-pkgrel=6
-pkgdesc="A low-latency, high quality voice chat software"
-url="http://wiki.mumble.info"
+pkgrel=7
+pkgdesc="Low-latency, high quality voice chat software"
+url="https://wiki.mumble.info"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
options="!check"
depends="qt-sqlite"
depends_dev=""
@@ -24,8 +24,15 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
+
+ CXXFLAGS="-std=c++11"
qmake -recursive main.pro \
CONFIG+="no-speechd no-g15 no-update no-ice bundled-celt no-embed-qt-translations no-bundled-speex"
+
+ # qmake-qt4 ignores complation *FLAGS thus patch the Makefiles directly
+ sed -i "s;^\(CXXFLAGS.*=.*\);& $CXXFLAGS;" \
+ */Makefile* */*/Makefile*
+
make release
}