aboutsummaryrefslogtreecommitdiffstats
path: root/community/roundcubemail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/roundcubemail/APKBUILD')
-rw-r--r--community/roundcubemail/APKBUILD24
1 files changed, 23 insertions, 1 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index 4c3a6e9997..17d8e4799d 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -26,9 +26,12 @@ depends="$_php
$_php-session
$_php-sockets
$_php-xml
- $_php-zip
ca-certificates
"
+_depends_managesieve="$_php-pear-net_sieve"
+_depends_zipdownload="$_php-zip"
+# Install plugins' deps during build just to verify that they exist.
+makedepends="$_depends_managesieve"
pkgusers="roundcube"
pkggroups="$pkgusers"
options="!check" # no tests provided
@@ -57,6 +60,15 @@ for _db in mssql mysql pgsql sqlite; do
subpackages="$subpackages $pkgname-$_db:_db"
done
+# List of plugins to move into subpackages.
+_plugins="
+ managesieve
+ zipdownload
+ "
+for _plugin in $_plugins; do
+ subpackages="$subpackages $pkgname-$_plugin:_plugin"
+done
+
_destdir="usr/share/webapps/roundcube"
prepare() {
@@ -166,6 +178,16 @@ _db() {
_mv "$pkgdir"/$_destdir/SQL/$rcname* "$subpkgdir"/$_destdir/SQL/
}
+_plugin() {
+ local name="${subpkgname#$pkgname-}"
+ pkgdesc="$pkgdesc ($name plugin)"
+ depends="$pkgname=$pkgver-r$pkgrel $(eval "echo \$_depends_$name")"
+
+ cd "$pkgdir"
+ _mv ./$_destdir/plugins/$name "$subpkgdir"/$_destdir/plugins/
+ _mv ./etc/roundcube/plugins/$name.inc.php "$subpkgdir"/etc/roundcube/plugins/
+}
+
_mv() {
local dest; for dest; do true; done # get last argument
mkdir -p "$dest"