aboutsummaryrefslogtreecommitdiffstats
path: root/community/telegram-cli/makefile-remove-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/telegram-cli/makefile-remove-werror.patch')
-rw-r--r--community/telegram-cli/makefile-remove-werror.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/telegram-cli/makefile-remove-werror.patch b/community/telegram-cli/makefile-remove-werror.patch
new file mode 100644
index 0000000000..19359d567d
--- /dev/null
+++ b/community/telegram-cli/makefile-remove-werror.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -4,7 +4,7 @@
+ LDFLAGS=@LDFLAGS@ @OPENSSL_LDFLAGS@
+ CPPFLAGS=@CPPFLAGS@ @OPENSSL_INCLUDES@
+ DEFS=@DEFS@
+-COMPILE_FLAGS=${CFLAGS} ${CPFLAGS} ${CPPFLAGS} ${DEFS} -Wall -Wextra -Werror -Wno-deprecated-declarations -fno-strict-aliasing -fno-omit-frame-pointer -ggdb -Wno-unused-parameter -fPIC
++COMPILE_FLAGS=${CFLAGS} ${CPFLAGS} ${CPPFLAGS} ${DEFS} -Wall -Wextra -Wno-deprecated-declarations -fno-strict-aliasing -fno-omit-frame-pointer -ggdb -Wno-unused-parameter -fPIC
+
+ EXTRA_LIBS=@LIBS@ @EXTRA_LIBS@ @OPENSSL_LIBS@
+ LOCAL_LDFLAGS=-rdynamic -ggdb -levent ${EXTRA_LIBS}