aboutsummaryrefslogtreecommitdiffstats
path: root/community/telegram-cli/makefile-tl-parser-nocrc32.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/telegram-cli/makefile-tl-parser-nocrc32.patch')
-rw-r--r--community/telegram-cli/makefile-tl-parser-nocrc32.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/telegram-cli/makefile-tl-parser-nocrc32.patch b/community/telegram-cli/makefile-tl-parser-nocrc32.patch
new file mode 100644
index 0000000000..7e16ef61de
--- /dev/null
+++ b/community/telegram-cli/makefile-tl-parser-nocrc32.patch
@@ -0,0 +1,16 @@
+--- a/tgl/Makefile.tl-parser
++++ b/tgl/Makefile.tl-parser
+@@ -1,4 +1,4 @@
+-TL_PARSER_OBJECTS=${OBJ}/tl-parser.o ${OBJ}/tlc.o ${OBJ}/crc32.o
++TL_PARSER_OBJECTS=${OBJ}/tl-parser.o ${OBJ}/tlc.o
+
+ ${TL_PARSER_OBJECTS}: ${OBJ}/%.o: ${srcdir}/tl-parser/%.c | create_dirs
+ ${CC} ${INCLUDE} ${COMPILE_FLAGS} -iquote ${srcdir}/tl-parser -c -MP -MD -MF ${DEP}/$*.d -MQ ${OBJ}/$*.o -o $@ $<
+--- a/Makefile.tl-parser
++++ b/Makefile.tl-parser
+@@ -1,4 +1,4 @@
+-TL_PARSER_OBJECTS=${OBJ}/tl-parser.o ${OBJ}/tlc.o ${OBJ}/crc32.o
++TL_PARSER_OBJECTS=${OBJ}/tl-parser.o ${OBJ}/tlc.o
+
+ ${TL_PARSER_OBJECTS}: ${OBJ}/%.o: ${srcdir}/tgl/tl-parser/%.c | create_dirs
+ ${CC} ${INCLUDE} ${COMPILE_FLAGS} -iquote ${srcdir}/tgl/tl-parser -c -MP -MD -MF ${DEP}/$*.d -MQ ${OBJ}/$*.o -o $@ $<