aboutsummaryrefslogtreecommitdiffstats
path: root/community/ucl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ucl/APKBUILD')
-rw-r--r--community/ucl/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/ucl/APKBUILD b/community/ucl/APKBUILD
new file mode 100644
index 0000000000..b9e73b9ae0
--- /dev/null
+++ b/community/ucl/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
+pkgname=ucl
+pkgver=1.03
+pkgrel=1
+pkgdesc="Portable lossless data compression library written in ANSI C"
+url="http://www.oberhumer.com/opensource/ucl/"
+arch="all"
+license="GPL2"
+makedepends="file"
+subpackages="$pkgname-dev"
+source="http://www.oberhumer.com/opensource/$pkgname/download/$pkgname-$pkgver.tar.gz
+ 0001-Static-assert.patch"
+
+prepare() {
+ default_prepare || return 1
+ update_config_sub || return 1
+ update_config_guess || return 1
+}
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --prefix=/usr \
+ --enable-shared \
+ --enable-static \
+ || return 1
+ make || return 1
+}
+
+check() {
+ cd "$builddir"
+ ./examples/simple
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="7dd1824d01b4bb41ee03bbceddc634a9f7f910d235e5cca163d783680d6743f0f3cc309bbbcc1e094d897d549d3805a555f9093b4d77805443d896dd1862aa34 ucl-1.03.tar.gz
+24a34de871fcfa919985afc29c60496b1f0e730550e8387f212a5229f32ccade4178d1221574d86c36d025c08b3b5ed6d236f2b4d740436afe0451ae9050f890 0001-Static-assert.patch"