aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/py-cffi/APKBUILD41
-rw-r--r--community/py-configargparse/APKBUILD40
-rw-r--r--community/py-cryptography/APKBUILD41
-rw-r--r--community/py-dialog/APKBUILD41
-rw-r--r--community/py-idna/APKBUILD40
-rw-r--r--community/py-ipaddress/APKBUILD41
-rw-r--r--community/py-ndg_httpsclient/APKBUILD40
-rw-r--r--community/py-parsedatetime/APKBUILD40
-rw-r--r--community/py-psutil/APKBUILD41
-rw-r--r--community/py-rfc3339/APKBUILD41
-rw-r--r--community/py-zope-component/APKBUILD41
-rw-r--r--community/py-zope-event/APKBUILD40
12 files changed, 487 insertions, 0 deletions
diff --git a/community/py-cffi/APKBUILD b/community/py-cffi/APKBUILD
new file mode 100644
index 0000000000..22b6546b6c
--- /dev/null
+++ b/community/py-cffi/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-cffi
+_pkgname=cffi
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="A foreign function interface for calling C code from python"
+url="http://cffi.readthedocs.org/"
+arch="all"
+license="MIT"
+depends="python py-cparser"
+depends_dev=""
+makedepends="python-dev py-setuptools libffi-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a40ed8c8ac653c8fc7d5603711b06eaf cffi-1.3.0.tar.gz"
+sha256sums="9daa53aff0b5cf64c85c10eab7ce6776880d0ee71b78cedeae196ae82b6734e9 cffi-1.3.0.tar.gz"
+sha512sums="2ea789d67782b2f23501bea4480f42f79e312d047e2d8c777aab8113400cfa136585aa92c0a51608a0da35cd6734bc24914fcccfc5bbdad3041aad2e9f784400 cffi-1.3.0.tar.gz"
diff --git a/community/py-configargparse/APKBUILD b/community/py-configargparse/APKBUILD
new file mode 100644
index 0000000000..6df32487f4
--- /dev/null
+++ b/community/py-configargparse/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-configargparse
+pkgver=0.9.3
+pkgrel=0
+pkgdesc="A drop-in replacement for argparse"
+url="https://github.com/zorro3/ConfigArgParse"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="ConfigArgParse-$pkgver.tar.gz::https://github.com/bw2/ConfigArgParse/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir"/ConfigArgParse-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="86e4fdba056c04035657b9575b4f38d6 ConfigArgParse-0.9.3.tar.gz"
+sha256sums="689bf143b016105374852eb80dd582faf26dafd7291bcd05368948a30ab0eee8 ConfigArgParse-0.9.3.tar.gz"
+sha512sums="9d31fe27bd6bdf7438b464dc1e691a648a2ca45711774aaa9d7a93387d61a7649139e5c00b6045b53f66e2f97d029c9ed41abeeafd5c61f56222e32abd4bc4d7 ConfigArgParse-0.9.3.tar.gz"
diff --git a/community/py-cryptography/APKBUILD b/community/py-cryptography/APKBUILD
new file mode 100644
index 0000000000..3a11dafdc3
--- /dev/null
+++ b/community/py-cryptography/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: August Klein <amatcoder@gmail.com>
+pkgname=py-cryptography
+_pkgname=cryptography
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="A package which provides cryptographic recipes and primitives"
+url="http://pypi.python.org/pypi/cryptography"
+arch="all"
+license="ASL 2.0"
+depends=""
+depends_dev="python-dev"
+makedepends="$depends_dev py-setuptools libffi-dev openssl-dev"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/c/cryptography/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6a8627da0c6199fca941dc8170f9b583 cryptography-1.0.2.tar.gz"
+sha256sums="d64cd491e91ddf642c643bea16532c2a2da2da054cca6df756edadd55a8bacca cryptography-1.0.2.tar.gz"
+sha512sums="f266fbee6ab06ed6a552599dffe6d3e959dd858e6be7b81c0d4489c384fbb2b5de5ecf4f1e43e1dacbaa6ddefd1562f10961caec73cb3ed256faa03a5d4eff85 cryptography-1.0.2.tar.gz"
diff --git a/community/py-dialog/APKBUILD b/community/py-dialog/APKBUILD
new file mode 100644
index 0000000000..97b111d358
--- /dev/null
+++ b/community/py-dialog/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-dialog
+pkgver=3.3.0
+pkgrel=0
+pkgdesc="A Python interface to the UNIX dialog utility and mostly-compatible programs"
+url="http://pythondialog.sourceforge.net/"
+arch="noarch"
+license="LGPL"
+depends="dialog"
+depends_dev=""
+makedepends="$depends_dev py-setuptools binutils"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/project/pythondialog/pythondialog/${pkgver}/python2-pythondialog-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/python2-pythondialog-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4fbea2c8d211c2bd49f239d76af4428e python2-pythondialog-3.3.0.tar.bz2"
+sha256sums="04e93f24995c43dd90f338d5d865ca72ce3fb5a5358d4daa4965571db35fc3ec python2-pythondialog-3.3.0.tar.bz2"
+sha512sums="3340d383cb9ccab1d5c6e7e73c6de5ba4ec24193746ae230a88d2f1e4d674c62707f058c8b0d200be2859f169d01d360314eb075d6dd84720d4cea47701f0cf7 python2-pythondialog-3.3.0.tar.bz2"
diff --git a/community/py-idna/APKBUILD b/community/py-idna/APKBUILD
new file mode 100644
index 0000000000..47789ec335
--- /dev/null
+++ b/community/py-idna/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-idna
+pkgver=2.0
+pkgrel=0
+pkgdesc="IDNA 2008 and UTS #46 for Python"
+url="https://github.com/kjd/idna"
+arch="noarch"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="idna-$pkgver.tar.gz::https://github.com/kjd/idna/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/idna-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9ef51e6e51ea91b6c62426856c8a5b7c idna-2.0.tar.gz"
+sha256sums="5858af065c0b00b6ac3265fa5c7efdf9896bccb7bbd486661941a8b1447e4eac idna-2.0.tar.gz"
+sha512sums="bea2fd4bfcc3607570e28752f95989b34ff6f875ba06231afd175d26be781e6c1388ea50af3de9b9682cadb4d5dbca232d607bd9700c857865326f87a8196ea7 idna-2.0.tar.gz"
diff --git a/community/py-ipaddress/APKBUILD b/community/py-ipaddress/APKBUILD
new file mode 100644
index 0000000000..390517dffb
--- /dev/null
+++ b/community/py-ipaddress/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-ipaddress
+pkgver=1.0.14
+pkgrel=0
+pkgdesc="IPv4/IPv6 manipulation library"
+url="https://github.com/phihag/ipaddress"
+arch="noarch"
+license="PSF"
+depends=""
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/i/ipaddress/ipaddress-$pkgver.tar.gz"
+
+_builddir="$srcdir"/ipaddress-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e2f2f6593b2b8a7e8abba0fbdf33f046 ipaddress-1.0.14.tar.gz"
+sha256sums="226f4be44c6cb64055e23060848266f51f329813baae28b53dc50e93488b3b3e ipaddress-1.0.14.tar.gz"
+sha512sums="fb33b484ca435f4e8817c735a1084f2fa749abca4643a10be644003fdb73cc9205fc28f484ef96d2db90e8b27d8a238d1d7cf20140f7942e39be12c7524e8d6f ipaddress-1.0.14.tar.gz"
diff --git a/community/py-ndg_httpsclient/APKBUILD b/community/py-ndg_httpsclient/APKBUILD
new file mode 100644
index 0000000000..a917c4d5c8
--- /dev/null
+++ b/community/py-ndg_httpsclient/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-ndg_httpsclient
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="HTTPS client implementation for httplib and urllib2 based on PyOpenSSL"
+url="https://github.com/cedadev/ndg_httpsclient"
+arch="noarch"
+license="BSD"
+depends="py-openssl py-asn1"
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="ndg_httpsclient-$pkgver.tar.gz::https://github.com/cedadev/ndg_httpsclient/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/ndg_httpsclient-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b7577b1eaa2a25915c7a963e0d2f80a5 ndg_httpsclient-0.4.0.tar.gz"
+sha256sums="d8954102b851dc775b12535d6623d41ee0849146ea8b8a2d937a5c12ca8ba19d ndg_httpsclient-0.4.0.tar.gz"
+sha512sums="4ff71ce7a475e2828e4836f77cbbcc6c9f99c6d5b0e4510b805be0e50f95a337665d73a54b355dc3ae51d752857dd886ba0c9c1dcc7d7041ebbed6df8842cd88 ndg_httpsclient-0.4.0.tar.gz"
diff --git a/community/py-parsedatetime/APKBUILD b/community/py-parsedatetime/APKBUILD
new file mode 100644
index 0000000000..64e4ed194a
--- /dev/null
+++ b/community/py-parsedatetime/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-parsedatetime
+pkgver=1.5
+pkgrel=0
+pkgdesc="Parse human-readable date/time strings"
+url="https://github.com/bear/parsedatetime"
+arch="noarch"
+license="Apache"
+depends=""
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="parsedatetime-$pkgver.tar.gz::https://github.com/bear/parsedatetime/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/parsedatetime-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f7b6b8258728ca9aa2ef536b3f221baf parsedatetime-1.5.tar.gz"
+sha256sums="4698420df9765f8f4ea41d9e771874ea8dff907e695f26634919b41f39590980 parsedatetime-1.5.tar.gz"
+sha512sums="cd76711f403e1344a6d4ac56c7d39ad280a47c10333a09ec2a65152b79f7a284d1d6ba3af7b7d7df9a32f650036012a115a3811d34f5dfe13582acec2ee5f130 parsedatetime-1.5.tar.gz"
diff --git a/community/py-psutil/APKBUILD b/community/py-psutil/APKBUILD
new file mode 100644
index 0000000000..b397d907aa
--- /dev/null
+++ b/community/py-psutil/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=py-psutil
+_pkgname=psutil
+pkgver=2.1.1
+pkgrel=0
+pkgdesc="A cross-platform process and system utilities module for Python"
+url="https://github.com/giampaolo/psutil"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="python-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root=$pkgdir/ --optimize=1 || return 1
+}
+
+md5sums="72a6b15d589fab11f6ca245b775bc3c6 psutil-2.1.1.tar.gz"
+sha256sums="bf812a4aa6a41147d0e96e63d826eb7582fda6b54ad8f22534354b7f8ac45593 psutil-2.1.1.tar.gz"
+sha512sums="c2194b49e450d243aaed4d846f95702e789dc422dc0199c04c8cd2f7695a2e3983dd7df21d7cc8aaec3abe38c19272ad958323c5c3e3eb9b548b507dd5b98587 psutil-2.1.1.tar.gz"
diff --git a/community/py-rfc3339/APKBUILD b/community/py-rfc3339/APKBUILD
new file mode 100644
index 0000000000..6bd2e4a06a
--- /dev/null
+++ b/community/py-rfc3339/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-rfc3339
+pkgver=0.2
+pkgrel=0
+pkgdesc="Generate and parse RFC 3339 timestamps"
+url="https://pypi.python.org/pypi/pyRFC3339"
+arch="noarch"
+license="MIT"
+depends="py-tz"
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/p/pyRFC3339/pyRFC3339-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pyRFC3339-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5e0f7e40e363812180fffaae52daf2e6 pyRFC3339-0.2.tar.gz"
+sha256sums="a504ff6bcb363fa402d393f65fe5f542475e54fbfc55817b80892ba93b22e6de pyRFC3339-0.2.tar.gz"
+sha512sums="54482528e429c0135823b333d18e6a9361ba99b18a62883e9b09f5533e75f08d12d9c1ee855296cecd98c11824f927984527bb0555a49e4284164b7fe4df8c4f pyRFC3339-0.2.tar.gz"
diff --git a/community/py-zope-component/APKBUILD b/community/py-zope-component/APKBUILD
new file mode 100644
index 0000000000..471c68f82f
--- /dev/null
+++ b/community/py-zope-component/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-zope-component
+_pkgname=zope.component
+pkgver=4.1.0
+pkgrel=0
+pkgdesc="Zope Component Architecture"
+url="https://pypi.python.org/pypi/zope.component"
+arch="noarch"
+license="ZPL2+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8e185893699f9fa577bd9ada0a5302fa zope.component-4.1.0.zip"
+sha256sums="6cb9eec6a735db27452b5825fb498684b5bff15bc0c26a7e1e5c9953a7588f4e zope.component-4.1.0.zip"
+sha512sums="438489717809982d7629e156e5252a689d0e6af5dc794688b270eddef47467fdac37cb32fa9a5f915a0303754a8365b4e05d61e6bad63228d7e3c63dba9263a0 zope.component-4.1.0.zip"
diff --git a/community/py-zope-event/APKBUILD b/community/py-zope-event/APKBUILD
new file mode 100644
index 0000000000..5b16cad0fa
--- /dev/null
+++ b/community/py-zope-event/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-zope-event
+pkgver=4.1.0
+pkgrel=0
+pkgdesc="Event publishing / dispatch, used by Zope Component Architecture"
+url="https://github.com/zopefoundation/zope.event"
+arch="noarch"
+license="ZPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="zope.event-$pkgver.tar.gz::https://github.com/zopefoundation/zope.event/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir"/zope.event-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9636c75fb1c6bfef793ef4ece25291b5 zope.event-4.1.0.tar.gz"
+sha256sums="a85cb6fd0e48e1147061eb0ecab57b9cc90f4c3b5609d63e5694a2d8de28ef47 zope.event-4.1.0.tar.gz"
+sha512sums="8a6dd253e65d76f91be6a4a006c63701a7a3a83a1341c67547cd294387a7b1b25f0d50fbd3fcc7c94d5bd49579534174837045e09823f8fdd6c35a5cff70e0e1 zope.event-4.1.0.tar.gz"