aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libnsl/APKBUILD14
-rw-r--r--community/libnsl/cdefs.patch28
-rw-r--r--community/libnsl/nis_h.patch5
3 files changed, 26 insertions, 21 deletions
diff --git a/community/libnsl/APKBUILD b/community/libnsl/APKBUILD
index 9e4c52952f..664e326047 100644
--- a/community/libnsl/APKBUILD
+++ b/community/libnsl/APKBUILD
@@ -1,19 +1,19 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=libnsl
-pkgver=1.0.5
-pkgrel=2
+pkgver=1.2.0
+pkgrel=0
pkgdesc="Public client interface for NIS(YP) and NIS+ in a IPv6 ready version"
url="https://github.com/thkukuk/libnsl"
arch="all"
license="LGPL-2.0-or-later"
makedepends="autoconf automake libtool libc-dev gettext-dev libtirpc-dev file"
subpackages="$pkgname-dev"
-source="https://github.com/thkukuk/$pkgname/archive/$pkgname-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/thkukuk/$pkgname/archive/v$pkgver.tar.gz
nis_h.patch
cdefs.patch
"
-builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
check() {
cd "$builddir"
@@ -40,6 +40,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ce0423042d372a9f800738480d222164e7ad2e09c9efa80d4845b9a06b78f478c395a65a4c175dd708d01f0bb9be9514526c44df48990221fd6d28c785767c49 libnsl-1.0.5.tar.gz
-6c555a8efab74eb55e0aaa2bef97d8ab14e382afaec59b99b47ff6f9abf4d33881f20543f88d41beabddfe934c368c4340c7254354fa9680120c0cc021df3468 nis_h.patch
-a0a761a50d611207cae4ad8e46b5b61fed498fe8c094841de99a550b43a0f95febcbccfafcd9568622abeb6e822f4bd9a21ecb261cb86fd8f4e601ce60749a9d cdefs.patch"
+sha512sums="30115aa679a04ad01f55cff9dd1890b4c41c730a9bac2adab5add9ae03a0b4687c5f4b6e3b8652ecbb074eefac8faee3f1f13ea60d42cf4432db8a575ca72cd8 libnsl-1.2.0.tar.gz
+bd120e3f8753c716c78484a9804a6314e6335bb1196cd4d456080eeee0b964a856f573885eff318725d1f0fab6a0092645e60a19602bf3f83983d53a0ee3c303 nis_h.patch
+d50a072d8bd42822d2c9c7e99d29e3a93e1df16a77ce46355b3e73268999e7b0cac6d39f214a28a81ac793a1fd672a39bf9fbdc9acc9a49760ab101d27c0eefc cdefs.patch"
diff --git a/community/libnsl/cdefs.patch b/community/libnsl/cdefs.patch
index dbbe800a34..a112b45bce 100644
--- a/community/libnsl/cdefs.patch
+++ b/community/libnsl/cdefs.patch
@@ -1,22 +1,25 @@
--- a/src/rpcsvc/nislib.h
+++ b/src/rpcsvc/nislib.h
-@@ -19,6 +19,7 @@
- #ifndef __RPCSVC_NISLIB_H__
- #define __RPCSVC_NISLIB_H__
+@@ -16,6 +16,8 @@
+ License along with the GNU C Library; if not, see
+ <http://www.gnu.org/licenses/>. */
+#include <sys/cdefs.h>
- #include <features.h>
-
- __BEGIN_DECLS
++
+ #ifndef __RPCSVC_NISLIB_H__
+ #define __RPCSVC_NISLIB_H__
+
--- a/src/rpcsvc/ypclnt.h
+++ b/src/rpcsvc/ypclnt.h
-@@ -20,6 +20,7 @@
- #ifndef __RPCSVC_YPCLNT_H__
- #define __RPCSVC_YPCLNT_H__
+@@ -16,6 +16,7 @@
+ License along with the GNU C Library; if not, see
+ <http://www.gnu.org/licenses/>. */
+#include <sys/cdefs.h>
- #include <features.h>
+ #ifndef __RPCSVC_YPCLNT_H__
+ #define __RPCSVC_YPCLNT_H__
+
/* Some defines */
--- a/src/rpcsvc/ypupd.h
+++ b/src/rpcsvc/ypupd.h
@@ -25,6 +28,7 @@
#define __RPCSVC_YPUPD_H__
+#include <sys/cdefs.h>
- #include <features.h>
-
#include <rpc/rpc.h>
+
+ #define MAXMAPNAMELEN 255
+
diff --git a/community/libnsl/nis_h.patch b/community/libnsl/nis_h.patch
index 199259df2e..1fc98e03dc 100644
--- a/community/libnsl/nis_h.patch
+++ b/community/libnsl/nis_h.patch
@@ -5,10 +5,10 @@
#define _RPCSVC_NIS_H 1
+#include <sys/cdefs.h>
- #include <features.h>
#include <rpc/rpc.h>
#include <rpcsvc/nis_tags.h>
-@@ -56,6 +57,34 @@
+
+@@ -57,6 +58,34 @@
* <kukuk@suse.de>
*/
@@ -43,3 +43,4 @@
#ifndef __nis_object_h
#define __nis_object_h
+