aboutsummaryrefslogtreecommitdiffstats
path: root/main/asterisk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/asterisk/APKBUILD')
-rw-r--r--main/asterisk/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index 072557bf3e..7e6c54dd81 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -69,6 +69,8 @@ prepare() {
build() {
cd "$_builddir"
+ # cannot build with imap on aarch64
+ [ "$CARCH" = "aarch64" ] || _imap="--with-imap"
SHA1SUM="$PWD"/build_tools/sha1sum-sh ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -99,7 +101,7 @@ build() {
--with-libcurl \
--with-libedit \
--with-srtp \
- --with-imap \
+ $_imap \
|| return 1
# get default modules to build