aboutsummaryrefslogtreecommitdiffstats
path: root/main/checkbashisms/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/checkbashisms/APKBUILD')
-rw-r--r--main/checkbashisms/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/checkbashisms/APKBUILD b/main/checkbashisms/APKBUILD
new file mode 100644
index 0000000000..05ec5b6b8a
--- /dev/null
+++ b/main/checkbashisms/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa
+pkgname=checkbashisms
+pkgver=2.0.0.2
+pkgrel=0
+pkgdesc="Basic checks on shell scripts for the presence of non portable syntax"
+url="http://sourceforge.net/projects/checkbaskisms/"
+arch="noarch"
+license="GPL"
+depends="perl"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/project/checkbaskisms/$pkgver/checkbashisms"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 "$srcdir"/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+md5sums="1261d0c5aafedc15ab4405c1969deacf checkbashisms"