aboutsummaryrefslogtreecommitdiffstats
path: root/main/http-parser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/http-parser/APKBUILD')
-rw-r--r--main/http-parser/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/main/http-parser/APKBUILD b/main/http-parser/APKBUILD
new file mode 100644
index 0000000000..b09115bcae
--- /dev/null
+++ b/main/http-parser/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=http-parser
+pkgver=2.7.1
+pkgrel=0
+pkgdesc="HTTP request/response parser for C"
+url="https://github.com/nodejs/http-parser"
+arch="all"
+license="MIT"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+# Note: All the patches are copied from Gentoo ebuild.
+# upstream: https://github.com/nodejs/http-parser/pull/272
+source="$pkgname-$pkgver.tar.gz::https://github.com/nodejs/$pkgname/archive/v$pkgver.tar.gz
+ 0001-makefile-fix-DESTDIR-usage.patch
+ 0002-makefile-quote-variables.patch
+ 0003-makefile-fix-SONAME-symlink-it-should-not-be-a-full-.patch
+ 0004-makefile-add-CFLAGS-to-linking-command.patch
+ 0005-makefile-fix-install-rule-dependency.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make library
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX="/usr"
+}
+
+md5sums="31c6fefb6208b16d19b3f990e71cb04a http-parser-2.7.1.tar.gz
+f6d5377fd3b5c91422bb2dcc2c4dce6c 0001-makefile-fix-DESTDIR-usage.patch
+859eff808165458c797353f0306ebc65 0002-makefile-quote-variables.patch
+8aea7eb27ae19ede7c8aed3d41c86d84 0003-makefile-fix-SONAME-symlink-it-should-not-be-a-full-.patch
+23d1e43dbf2deffb38488d54cce62f96 0004-makefile-add-CFLAGS-to-linking-command.patch
+fd7ffe7e725f866232f3b2850d164256 0005-makefile-fix-install-rule-dependency.patch"
+sha256sums="70409ad324e5de2da6a0f39e859e566d497c1ff0a249c0c38a5012df91b386b3 http-parser-2.7.1.tar.gz
+785012d9e0efb70c4dcc137f354ab57afabdcb0fb7c8cb2580c3c4a7e9add330 0001-makefile-fix-DESTDIR-usage.patch
+80fdf673731f27f328d45f4da7daa613613d8db40f1dc84d2ce65fad0130c054 0002-makefile-quote-variables.patch
+9854f5f205ec0959cc10cab80d16ff54f33a9979e5fd310ba9a4624b60c84ee9 0003-makefile-fix-SONAME-symlink-it-should-not-be-a-full-.patch
+e69fa304327dbb0626edaf147b73dc9fb4718b656b225794a04937206929c0df 0004-makefile-add-CFLAGS-to-linking-command.patch
+04898654adef3f3dbf1e29e66f8e9fc4467f68389e224beb03387d33ee263212 0005-makefile-fix-install-rule-dependency.patch"
+sha512sums="c0fe86455db1a563a5c668f118dfa9a27b9a637ee1c0e2f2f18a5b816352436ed90435ea978e3f3d85b037d3c630234e47d609dc3b7086b898286c4e54d9f031 http-parser-2.7.1.tar.gz
+ebb481df21cb312824ed65e7d6a3e7b237451071235566595da97c09b165767693ec3c47c27c451bfbdc2d62cc45c7d5d9f996b80789dc7fedaa2543c94c9065 0001-makefile-fix-DESTDIR-usage.patch
+3637abedbf330af0f4a9721081db99fe0f6400322f21f77ab16d580546a9d200d40bc584e8dbb51adec249c2d468730c6e2487ccda3786626909d988b7f8856a 0002-makefile-quote-variables.patch
+8202d665963234ce6dd84439f281921cb959424024c2fec8a27b65693b3466cab8674a3549d22fdb2fc07edf69f94440368ef77738ae4be2a5d94c13e3c814bb 0003-makefile-fix-SONAME-symlink-it-should-not-be-a-full-.patch
+e18c163f2069795fb6b744ad9f6e44eb9efca7f560460a6759bc0121a404bfe8109031c0f43d36d4987bda3411e0a433dbab6d0eabb2dbb5c79f1ce878251aae 0004-makefile-add-CFLAGS-to-linking-command.patch
+4cd120f406eeeb1e5a60c7d8955cdfead50d99b60f91a0fcdb2ae19403d08e5ed5619885c9e434ce40ffb442b317ee8c32ef636960429036f9bff92492f03968 0005-makefile-fix-install-rule-dependency.patch"