aboutsummaryrefslogtreecommitdiffstats
path: root/main/http-parser
diff options
context:
space:
mode:
Diffstat (limited to 'main/http-parser')
-rw-r--r--main/http-parser/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/http-parser/APKBUILD b/main/http-parser/APKBUILD
index b09115bcae..38ed90d360 100644
--- a/main/http-parser/APKBUILD
+++ b/main/http-parser/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=http-parser
pkgver=2.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="HTTP request/response parser for C"
url="https://github.com/nodejs/http-parser"
arch="all"
@@ -26,6 +26,11 @@ build() {
make library
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
make install DESTDIR="$pkgdir" PREFIX="/usr"