aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-sec
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-sec')
-rw-r--r--main/lua-sec/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/lua-sec/APKBUILD b/main/lua-sec/APKBUILD
index fb4f0d1f40..6ca5f9daf6 100644
--- a/main/lua-sec/APKBUILD
+++ b/main/lua-sec/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-_luaversions="5.1 5.2"
+_luaversions="5.1 5.2 5.3"
pkgname=lua-sec
pkgver=0.5
-pkgrel=0
+pkgrel=1
pkgdesc="TLS/SSL Support for Lua"
url="https://github.com/brunoos/luasec/wiki"
arch="all"
@@ -14,7 +14,6 @@ makedepends="openssl-dev"
install=
subpackages="$pkgname-doc"
for _i in $_luaversions; do
- depends="$depends lua$_i-sec"
makedepends="$makedepends lua$_i-dev"
subpackages="$subpackages lua$_i-sec:split_${_i/./_}"
done
@@ -57,6 +56,7 @@ package() {
_split() {
local d= _ver=$1
pkgdesc="TLS/SSL Support for Lua $_ver"
+ install_if="lua$_ver $pkgname=$pkgver-r$pkgrel"
replaces="$pkgname"
depends="lua$_ver-socket"
for d in usr/lib/lua usr/share/lua; do