aboutsummaryrefslogtreecommitdiffstats
path: root/main/lxc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lxc/APKBUILD')
-rw-r--r--main/lxc/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 7b8ac65763..2e7daf49ef 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -5,7 +5,7 @@
pkgname=lxc
pkgver=2.1.0
_pkgver=${pkgver/_rc/.rc}
-pkgrel=0
+pkgrel=1
pkgdesc="Userspace interface for the Linux kernel containment features"
url="https://linuxcontainers.org/lxc/"
arch="all"
@@ -130,6 +130,7 @@ bridge() {
ln -s dnsmasq "$subpkgdir"/etc/init.d/dnsmasq.lxcbr0
cat >>"$subpkgdir"/etc/conf.d/dnsmasq.lxcbr0 <<- EOF
+ rc_before="lxc"
BRIDGE_ADDR="10.0.3.1"
BRIDGE_NETMASK="255.255.255.0"
BRIDGE_NETWORK="10.0.3.0/24"
@@ -142,9 +143,6 @@ EOF
#dhcp-host=somehost,10.0.3.3
#dhcp-host=otherhost,10.0.3.4
EOF
- cat >>"$subpkgdir"/etc/conf.d/lxc <<- EOF
- rc_need="dnsmasq.lxcbr0"
-EOF
}