aboutsummaryrefslogtreecommitdiffstats
path: root/main/nghttp2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nghttp2/APKBUILD')
-rw-r--r--main/nghttp2/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/nghttp2/APKBUILD b/main/nghttp2/APKBUILD
index d263a26ef1..7c4780605d 100644
--- a/main/nghttp2/APKBUILD
+++ b/main/nghttp2/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nghttp2
pkgver=1.31.0
-pkgrel=0
+pkgrel=1
pkgdesc="Experimental HTTP/2 client, server and proxy"
url="https://nghttp2.org/"
arch="all"
license="MIT"
-makedepends="libev-dev libressl-dev zlib-dev c-ares-dev"
+makedepends="libev-dev libressl-dev zlib-dev c-ares-dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
+source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz
+ libressl-2.7.patch"
builddir="$srcdir"/$pkgname-$pkgver
check() {
@@ -19,6 +20,7 @@ check() {
build() {
cd "$builddir"
+ autoreconf -vif
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,4 +44,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="00342b0517eb9e1044eced4649488d7ad35694e0a1303c4cba2d2be897fb86c5c70f1a5a157799d5c0cf448a6b983f2a2a57ee2bdb5ec762876647f9303446ca nghttp2-1.31.0.tar.xz"
+sha512sums="00342b0517eb9e1044eced4649488d7ad35694e0a1303c4cba2d2be897fb86c5c70f1a5a157799d5c0cf448a6b983f2a2a57ee2bdb5ec762876647f9303446ca nghttp2-1.31.0.tar.xz
+b6d2fea4d76253cc7e8a4387f77fbde8f2b7aec09ec7c48ccd7c499571786244c29ec917714b37eb458404351b179bb0af0c62c150450114b59f47d5c44f8dd7 libressl-2.7.patch"