aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-plack/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-plack/APKBUILD')
-rw-r--r--main/perl-plack/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/main/perl-plack/APKBUILD b/main/perl-plack/APKBUILD
new file mode 100644
index 0000000000..6746ef0932
--- /dev/null
+++ b/main/perl-plack/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-plack
+pkgver=0.9979
+pkgrel=0
+pkgdesc="Plack perl module"
+url="http://search.cpan.org/dist/Plack/"
+arch="noarch"
+license="GPLv2 or Artistic"
+depends="perl
+ perl-devel-stacktrace
+ perl-devel-stacktrace-ashtml
+ perl-file-sharedir
+ perl-filesys-notify-simple
+ perl-http-body
+ perl-test-tcp
+ perl-hash-multivalue
+ perl-libwww
+ perl-try-tiny
+ perl-uri
+ "
+makedepends="perl-dev perl-test-requires"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Plack-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Plack-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="8361de1b1b628b5e82f556429bba8095 Plack-0.9979.tar.gz"