aboutsummaryrefslogtreecommitdiffstats
path: root/main/py2-fasteners/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py2-fasteners/APKBUILD')
-rw-r--r--main/py2-fasteners/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/py2-fasteners/APKBUILD b/main/py2-fasteners/APKBUILD
new file mode 100644
index 0000000000..96e6a1f0d6
--- /dev/null
+++ b/main/py2-fasteners/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=py2-fasteners
+pkgver=0.14.1
+pkgrel=0
+pkgdesc="A python package that provides useful locks"
+url="https://github.com/harlowja/fasteners/"
+arch="noarch"
+license="Apache-2.0"
+depends="python2 py2-monotonic py2-six"
+makedepends="python2-dev py-setuptools"
+source="fasteners-$pkgver.tar.gz::https://github.com/harlowja/fasteners/archive/$pkgver.tar.gz"
+sha512sums="954d692b7f43563ba1413854c8dec2f5ff98757346c55aaa5f39e9aa777fb746bf4f9506beab6cfa149d5646db4b3de58d35bcef95e3128096c3346c9fd8015c fasteners-0.14.1.tar.gz"
+builddir="$srcdir/fasteners-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+