aboutsummaryrefslogtreecommitdiffstats
path: root/main/sed
diff options
context:
space:
mode:
Diffstat (limited to 'main/sed')
-rw-r--r--main/sed/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/main/sed/APKBUILD b/main/sed/APKBUILD
index 45187e0d31..3d9ca4efe3 100644
--- a/main/sed/APKBUILD
+++ b/main/sed/APKBUILD
@@ -14,6 +14,13 @@ source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
builddir="$srcdir/$pkgname-$pkgver"
+# XXX -- ugly hack to unbreak x86 builder, don't try this at home kids. we invoke a suid helper to delete sed, forcing
+# busybox sed to be used. hopefully you don't ever see this as i will revert it next...
+prepare() {
+ default_prepare || return 1
+ abuild-apk del sed || return 1
+}
+
build() {
cd "$builddir"
./configure \