aboutsummaryrefslogtreecommitdiffstats
path: root/main/texinfo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/texinfo/APKBUILD')
-rw-r--r--main/texinfo/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/main/texinfo/APKBUILD b/main/texinfo/APKBUILD
index 0b2640fea2..4ddfad2c51 100644
--- a/main/texinfo/APKBUILD
+++ b/main/texinfo/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=texinfo
pkgver=6.5
-pkgrel=0
+pkgrel=1
pkgdesc="Utilities to work with and produce manuals, ASCII text, and on-line documentation from a single source file"
url="https://www.gnu.org/software/texinfo/"
arch="all"
-license='GPL3+'
+options="!check" # Test dependencies are not packaged
+license="GPL-3.0+"
depends="perl"
makedepends="ncurses-dev perl-dev"
subpackages="$pkgname-doc"
@@ -17,14 +18,13 @@ build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir"/ install || return 1
+ make DESTDIR="$pkgdir"/ install
rm -f "$pkgdir"/usr/share/info/dir
gzip "$pkgdir"/usr/share/info/*