aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/binutils/APKBUILD3
-rw-r--r--main/build-base/APKBUILD4
-rw-r--r--main/gcc/APKBUILD4
3 files changed, 7 insertions, 4 deletions
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index add96323a4..693a0b7667 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
pkgver=2.31.1
-pkgrel=1
+pkgrel=2
pkgdesc="Tools necessary to build programs"
url="https://www.gnu.org/software/binutils/"
depends=""
@@ -19,6 +19,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
gold-mips.patch
"
builddir="$srcdir/$pkgname-$pkgver"
+options=toolchain
if [ "$CHOST" != "$CTARGET" ]; then
pkgname="$pkgname-$CTARGET_ARCH"
diff --git a/main/build-base/APKBUILD b/main/build-base/APKBUILD
index 01b89d94c2..a2ea32ebeb 100644
--- a/main/build-base/APKBUILD
+++ b/main/build-base/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=build-base
pkgver=0.5
-pkgrel=1
+pkgrel=2
url=http://dev.alpinelinux.org/cgit
pkgdesc="Meta package for build base"
depends="binutils file gcc g++ make libc-dev fortify-headers"
@@ -12,7 +12,7 @@ if [ "$CHOST" != "$CTARGET" ]; then
fi
arch="noarch"
license=none
-options="!check"
+options="!check toolchain"
build() {
:
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index e19eddea68..22219f8eb0 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -6,7 +6,7 @@ pkgver=8.2.0
[ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
pkgname="$pkgname$_target"
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -18,6 +18,7 @@ makedepends_host="linux-headers gmp-dev mpfr-dev mpc1-dev isl-dev zlib-dev !gett
subpackages=" "
[ "$CHOST" = "$CTARGET" ] && subpackages="gcc-doc$_target"
replaces="libstdc++ binutils"
+options=toolchain
: ${LANG_CXX:=true}
: ${LANG_OBJC:=true}
@@ -37,6 +38,7 @@ if [ "$CHOST" != "$CTARGET" ]; then
LIBGCC=false
_builddir="$srcdir/build-cross-pass2"
else
+ makedepends_target="musl musl-dev"
_builddir="$srcdir/build-cross-final"
fi
LANG_OBJC=false