aboutsummaryrefslogtreecommitdiffstats
path: root/testing/frr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/frr/APKBUILD')
-rw-r--r--testing/frr/APKBUILD67
1 files changed, 0 insertions, 67 deletions
diff --git a/testing/frr/APKBUILD b/testing/frr/APKBUILD
deleted file mode 100644
index 374c242744..0000000000
--- a/testing/frr/APKBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# Maintainer: Arthur Jones <arthur.jones@riverbed.com>
-pkgname=frr
-pkgver=5.0.1
-pkgrel=0
-pkgdesc="FRRouting is a fork of quagga"
-pkgusers="frr"
-pkggroups="frr"
-url="https://frrouting.org/"
-arch="x86_64"
-license="GPL-2.0-only and LGPL-2.1-only"
-depends="json-c c-ares iproute2 python py-ipaddr bash"
-makedepends="ncurses-dev net-snmp-dev gawk texinfo perl
- acct autoconf automake bash bison bsd-compat-headers
- c-ares-dev cryptsetup-libs device-mapper-libs flex
- json-c-dev kmod lddtree libacl libblkid libburn libedit
- libisoburn libisofs libltdl libtool libuuid linux-headers lzo m4 mkinitfs
- mtools pcre perl python2-dev readline-dev
- squashfs-tools texinfo xorriso py-sphinx"
-checkdepends="pytest py-setuptools"
-install="$pkgname.pre-install $pkgname.pre-deinstall $pkgname.post-deinstall"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg $pkgname-openrc"
-source="https://github.com/FRRouting/frr/archive/$pkgname-$pkgver.tar.gz
- make-check-bypass-isisd-tlv.patch
- frr
- "
-builddir="$srcdir"/$pkgname-$pkgname-$pkgver
-
-_sbindir=/usr/lib/frr
-_sysconfdir=/etc/frr
-_libdir=/usr/lib
-_localstatedir=/var/run/frr
-
-build() {
- cd "$builddir"
- ./bootstrap.sh
- ./configure \
- --prefix=/usr \
- --sbindir=$_sbindir \
- --sysconfdir=$_sysconfdir \
- --libdir=$_libdir \
- --localstatedir=$_localstatedir \
- --enable-systemd=no \
- --enable-vtysh \
- --enable-multipath=64 \
- --enable-vty-group=frrvty \
- --enable-user=${pkgusers%% *} \
- --enable-group=${pkggroups%% *}
- make
-}
-
-check() {
- cd "$builddir"
-
- make -j 1 check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-
- install -Dm644 "$builddir"/tools/etc/frr/daemons "$pkgdir"$_sysconfdir
- install -Dm644 "$builddir"/tools/etc/frr/daemons.conf "$pkgdir"$_sysconfdir
- install -Dm755 "$srcdir"/frr "$pkgdir"/etc/init.d/frr
-}
-sha512sums="e2a3a4e21998f8c85b59fc971190d0b5340bbcd88356a637740ad8e564275b0df14da78b72a24a99a58435725cded1b9089814fc926a7a4080bd3a8762973548 frr-5.0.1.tar.gz
-3c679b857018d82443abd34823e712a8657a597b4210730d260e9796516982a137234354422cb439989985367531d600e205d3fb791cdb7b212425bb704c2016 make-check-bypass-isisd-tlv.patch
-c8c568c97925191a66d51921a93f86b87b1f47180900528deb96cb91c3a2ee3b8e0874e6397ed7d1406f396d6f1e5afb847155feec74d3f00bb3329dd7d9f0b0 frr"