aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hexchat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hexchat/APKBUILD')
-rw-r--r--testing/hexchat/APKBUILD61
1 files changed, 0 insertions, 61 deletions
diff --git a/testing/hexchat/APKBUILD b/testing/hexchat/APKBUILD
deleted file mode 100644
index c8a9135231..0000000000
--- a/testing/hexchat/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=hexchat
-pkgver=2.9.6.1
-pkgrel=0
-pkgdesc="A popular and easy to use graphical IRC (chat) client"
-url="http://www.hexchat.org"
-arch="all"
-license="GPLv2+"
-depends=""
-makedepends="gtk+2.0-dev openssl-dev dbus-glib-dev perl-dev
- libsexy-dev python-dev libnotify-dev libproxy-dev
- bash libtool autoconf automake"
-install=""
-subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
-source="http://dl.hexchat.org/hexchat/hexchat-$pkgver.tar.xz"
-
-_builddir="$srcdir"/hexchat-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- NOCONFIGURE=1 ./autogen.sh
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --enable-openssl \
- --enable-dbus \
- --disable-textfe \
- --disable-perl \
- --enable-python \
- --enable-ipv6 \
- --enable-shm \
- --enable-spell=libsexy || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/lib/hexchat/plugins/*.la || return 1
- # not worth a -dev pkg
- rm -r "$pkgdir"/usr/include
-}
-
-_python() {
- pkgdesc="Python plugin for hexchat"
- mkdir -p "$subpkgdir"/usr/lib/hexchat/plugins
- mv "$pkgdir"/usr/lib/hexchat/plugins/python.so \
- "$subpkgdir"/usr/lib/hexchat/plugins
-}
-
-md5sums="4723f43afc65a973ceddbea0173ff416 hexchat-2.9.6.1.tar.xz"
-sha256sums="6267ff3c4d0aec8a808365b384115a769d5001d99dbb10403634667c43966470 hexchat-2.9.6.1.tar.xz"
-sha512sums="73a7c2818b9d59a62c2471b9010cd04a6a5ac85b22d5158fdc27831d8700f09eb3011aac341866b76d7a4efe483f59de9c7b6d9a983916ccfbf8e61db81ea195 hexchat-2.9.6.1.tar.xz"