aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-billiard
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-billiard')
-rw-r--r--testing/py-billiard/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-billiard/APKBUILD b/testing/py-billiard/APKBUILD
new file mode 100644
index 0000000000..81ad60b5cb
--- /dev/null
+++ b/testing/py-billiard/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-billiard
+pkgver=3.5.0.3
+pkgrel=0
+pkgdesc="a message queue abstraction layer"
+url="https://pypi.python.org/pypi/billiard/"
+arch="all"
+license="BSD"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-billiard:py2 py3-billiard:py3"
+source="https://files.pythonhosted.org/packages/source/b/billiard/billiard-$pkgver.tar.gz"
+builddir="$srcdir/billiard-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="f3a98e9b7af8c0b5741bcea915c0ff8d6e32e26d79637d14fc09ea85dd80693ea8205e13ac2d86e5035c377fdd6d769a2647b005dc10af8b106c75464458a808 billiard-3.5.0.3.tar.gz"