aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-praw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-praw/APKBUILD')
-rw-r--r--testing/py-praw/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-praw/APKBUILD b/testing/py-praw/APKBUILD
new file mode 100644
index 0000000000..f899ae8ecc
--- /dev/null
+++ b/testing/py-praw/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-praw
+_pkgname=praw
+pkgver=2.1.8
+pkgrel=0
+pkgdesc="A Python module to access to reddit's API"
+url="https://github.com/praw-dev/praw"
+arch="noarch"
+license="GPL3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5d1b28c9339ddb46f4df344ba243c0d8 praw-2.1.8.tar.gz"
+sha256sums="88316b09e4bd0ab5b0f6efebaf2ffd1941a92a6eead19fac5dda14da47535647 praw-2.1.8.tar.gz"
+sha512sums="1dcea658943d1eed70309b33260496f4d94db7fe841e561728695c31165f181d47b22182b7a79022099b45ea2737c13efbc88c47ddac4d68a0943c4527ca081c praw-2.1.8.tar.gz"