aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-rpio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-rpio/APKBUILD')
-rw-r--r--testing/py-rpio/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-rpio/APKBUILD b/testing/py-rpio/APKBUILD
new file mode 100644
index 0000000000..26da2be375
--- /dev/null
+++ b/testing/py-rpio/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-rpio
+_pkgname=RPIO
+pkgver=0.10.0
+pkgrel=0
+pkgdesc="GPIO toolbox for the Raspberry Pi"
+url="https://github.com/metachris/RPIO"
+arch="all"
+license="LGPLv3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="cefc45422833dcafcd59b78dffc540f4 RPIO-0.10.0.tar.gz"
+sha256sums="b89f75dec9de354681209ebfaedfe22b7c178aacd91a604a7bd6d92024e4cf7e RPIO-0.10.0.tar.gz"
+sha512sums="6b366d47809e0f1b3733316821bdebd02a202cdf4a31f67fda07aa806cfcf546bd2a38644e25d481ec0d6fd2210ea697fdc0d0f3e57340ab40d81d7e275f483c RPIO-0.10.0.tar.gz"