aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xulrunner/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/xulrunner/APKBUILD')
-rw-r--r--testing/xulrunner/APKBUILD175
1 files changed, 175 insertions, 0 deletions
diff --git a/testing/xulrunner/APKBUILD b/testing/xulrunner/APKBUILD
new file mode 100644
index 0000000000..5ca7140bdc
--- /dev/null
+++ b/testing/xulrunner/APKBUILD
@@ -0,0 +1,175 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xulrunner
+pkgver=32.0
+_ffoxver=$pkgver
+pkgrel=0
+pkgdesc="runtime environment for xul-based applications"
+url="http://developer.mozilla.org/en/XULRunner"
+arch="all"
+license="GPL LGPL MPL"
+depends=
+depends_dev="nspr-dev
+ nss-dev
+ gtk+-dev
+ dbus-glib-dev
+ alsa-lib-dev
+ gstreamer1-dev
+ gst-plugins-base1-dev
+ libvorbis-dev
+ libogg-dev
+ libtheora-dev
+ wireless-tools-dev
+ libnotify-dev
+ libevent-dev
+ libvpx-dev
+ libxt-dev
+ libjpeg-turbo-dev
+ bzip2-dev
+ hunspell-dev
+ startup-notification-dev
+ sqlite-dev
+ libidl-dev
+ mesa-dev
+ icu-dev"
+makedepends="$depends_dev
+ autoconf2.13
+
+ sed
+ python
+ zip
+ yasm
+ paxctl
+
+ autoconf
+ automake
+ libtool"
+install=""
+options=""
+subpackages="$pkgname-dev $pkgname-dbg"
+source="ftp://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2
+ 0002-Use-C99-math-isfinite.patch
+ 0003-xulrunner-jemalloc-aslr.patch
+ getchar.patch
+ stat.patch
+ fix-arm-atomics-grsec.patch
+
+ fix-ipc.patch
+ fix-media.patch
+ fix-media-webrtc.patch
+ fix-netwerk.patch
+ fix-toolkit.patch
+ fix-tools.patch
+ mozilla-build-arm.patch
+
+ stab.h
+ mozconfig
+ "
+
+# help our shared-object scanner to find the libs
+ldpath="/usr/lib/xulrunner-$pkgver"
+
+_builddir="${srcdir}/mozilla-release"
+prepare() {
+ local i
+
+ cd "$_builddir"
+
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ cp "${srcdir}/mozconfig" .mozconfig || return 1
+ sed -e "s/#${CLIBC}#//g" -i .mozconfig
+
+ cp "$srcdir"/stab.h toolkit/crashreporter/google-breakpad/src/
+}
+
+build() {
+ cd "$_builddir"
+
+ # mozilla's buildsystem is on drugs, so we just kill our CFLAGS and hope
+ # for the best. --nenolod
+ unset CFLAGS
+ unset CXXFLAGS
+
+ make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ # only used for startupcache creation.
+ local paxflags="-m"
+ [ "$CARCH" = "x86" ] && paxflags="-msp"
+ paxctl -c $paxflags */dist/bin/xpcshell || return 1
+
+ make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1
+
+ # make install does not install xpt.py but its needed by firefox
+ mkdir -p "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin
+ cp xpcom/typelib/xpt/tools/xpt.py \
+ "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin/
+
+ msg "Setting up compatibility symlinks..."
+ ln -sf /usr/lib/xulrunner-${pkgver}/libxul.so "${pkgdir}"/usr/lib/libxul.so
+ ln -sf /usr/lib/xulrunner-${pkgver}/libmozalloc.so "${pkgdir}"/usr/lib/libmozalloc.so
+}
+
+dev() {
+ replaces="xulrunner"
+ depends="xulrunner"
+
+ mkdir -p "${subpkgdir}"/usr/lib
+ mv "${pkgdir}"/usr/lib/xulrunner-devel-${pkgver} "${subpkgdir}"/usr/lib
+ mv "${pkgdir}"/usr/lib/pkgconfig "${subpkgdir}"/usr/lib
+ mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
+}
+
+md5sums="859d0b6fe2d36b6959cf08cee4c783cc firefox-32.0.source.tar.bz2
+f43c1f0ae57aa8289b130c6de8caf3ce 0002-Use-C99-math-isfinite.patch
+e8b3a22d670241bb5c038729ac49a975 0003-xulrunner-jemalloc-aslr.patch
+507742325de8687529e4e81e31132ddf getchar.patch
+d9a2245b93a7f5855ee029b5fa44e4e9 stat.patch
+b18bd948aae828e5c8f5f63e440c96d6 fix-arm-atomics-grsec.patch
+38a9c0d5be155164d50a956ac131d991 fix-ipc.patch
+f8bc97333847f37597c0bac0dca64eb2 fix-media.patch
+ce4839160acf3986a2118326ed2b8444 fix-media-webrtc.patch
+170b8e7f8cab21f0965f226c291a57f9 fix-netwerk.patch
+296954be4c6d6bfcc24d0a46a2bd7d74 fix-toolkit.patch
+2279c55a85013fc1c0d01427768edd4d fix-tools.patch
+308ba5b54116a035fe68d0d5c3974857 mozilla-build-arm.patch
+4383d038b8d8411ea46f4a109197c19e stab.h
+7701fb5564182cced00b2b45bce39685 mozconfig"
+sha256sums="3265971e15809ab904403b474fa9eccf15f34697deb16fc400c5c3684afd50eb firefox-32.0.source.tar.bz2
+2f319883300f2aef180bfb80221151fcbb29344a5a0a086d6ad1d80005daf039 0002-Use-C99-math-isfinite.patch
+324d5cd26858ad21bb4680db8635fb3fd014bf00a637bf9fb2b118c2925fc5e7 0003-xulrunner-jemalloc-aslr.patch
+d14357bf44f702d94b8d3ed79bdf81f6271370745c1ac8fa83522bd98be4adc4 getchar.patch
+a0f8a0fa9977ee43f3853b6c6bf5a506fdfabdfa32b4279e0ac3d7a3078f34cc stat.patch
+ff7cb3c9c4712e0517a6f11e3bf08e9b0d13dbe6384930bdc7f55b1ceed039b5 fix-arm-atomics-grsec.patch
+059a69ff0dbceeaa5bbb1446aa4233bc578a047fcad22c0efa27dc64bbd72980 fix-ipc.patch
+c1d0fbcf5e8610df9adc66ea956753e7d495e8ed2d1c1e06d183f4680c85db97 fix-media.patch
+3e53af8beff122bcf5790c148fb51f41f44b6fe5dd5799777b70c3542c32cb93 fix-media-webrtc.patch
+4a2f8ff5e9b1359541eba8854098cee2caeb40ad9dbdc4b8fcf48b47ea8ca2d2 fix-netwerk.patch
+666883189dba3f4c7ba6b5bc85026c85bcb84477c2d5ba00d6414ddd0f744368 fix-toolkit.patch
+60ed0870119480994c6c455034c52dd21b8482b7617c3a0032e3b2abf4467e4d fix-tools.patch
+6f5f5e4d2a17182b72b248e896450235ccdaf63252fdb89a8deb55da8adc9be3 mozilla-build-arm.patch
+960d82bbfdc88c95f5cb4f2e1c1bf23dae7519b3b7203914d7b3ddbff1ba4c28 stab.h
+bfc5a101a6a50490dc865b4b7cae94be5e4fad9ecd6b5bcccdd8380eeb1d1a71 mozconfig"
+sha512sums="e9422c92846bda9dfa4da914be1206c41a8edde7e8bb13d81211433fc2c9013bbaee9bded40f7acf031d675272b04d7902d5631d2932daa3a8a594f768c87974 firefox-32.0.source.tar.bz2
+9a6666a3b637549411ea562c9d0d6d617ed48327d0f9e4e64d27f43774c218e6c5cf5fa99d4b339a5a0f89b854a18079392eba0dafc3419adbd4cdd5d71d3f26 0002-Use-C99-math-isfinite.patch
+46caf196a9f68614c42b793befc7dc85438d30ce47c06ccc925aae14728d67b0d29192edba430c0a6237192e6d51db26dfc6e6190bc01937a828effd8136f37b 0003-xulrunner-jemalloc-aslr.patch
+18f0696bf4d032c83041110b83ae6531b48474a778fc1deade3b06ba2ae1bfcc9891059287bfb78317c2f5ddc88f5b7ce957312acdb63d4902a57e0b40eb6520 getchar.patch
+1a8754830dbbf5432a611504c957c4ff24fdc31dc1a5ee7cdd4240bc5c084baa26a24f18527ff398ec81e56a36aee31732138243cf22a6bab89703656ff463e7 stat.patch
+4311464ae52b6d2e2b02c789c6d5fca9b3c211888a983aa609a62c2f2554516fea735ea90673387c69b38a30aa8453ed79faa44b5163df4293880d40df676b2d fix-arm-atomics-grsec.patch
+3f360d4231355c268fc52e0fedbce5c4f73ad8d60d9424af8641733c0ae181e6226056e605f0d6653b729a9c8e4abe97a9fb2face25938651a7498d5753cea8b fix-ipc.patch
+f4d1b0814247cdfe1655a0f345def4f80bd66f37ae5b0edc2cd6b8358e39e9a1bcc0a4ed7d1c4074a1302fb027a2f8be549225c5f4f56caf2513c968ed05d666 fix-media.patch
+a5d00272fc9e2b3a786f5891bac11b04ffaf6dfcbd2b30cba42286b79d12fefb6cb9c81e6d75987ab3ee19d12af20a074c77edc655bd470be06f5025eb38e609 fix-media-webrtc.patch
+8a896ee4d1465a844351cec84217de1a28b9f27bfc1e34cc71368664b5b8804bd66bdcadc78c78ee365abd1d0cafed1e6c568045c93cb78ac94e2818f503d58c fix-netwerk.patch
+72459754016f254c58d56d9a8719897fa8da9cf969eaa498e1e755457942d3f0ac56e4abd3f6a66ef924c94aa034d0af18a1fb653926b2496f0c2615fdb24c5e fix-toolkit.patch
+426b57ce698de3eecd1b52f2998974c4e0b5922584b09b554d436c61fee039d1f86345e746fee067801ebbf50815c4d19b96266a2ed72a35ae5c3edbdb57bba1 fix-tools.patch
+e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb18b9e3138273ea8ddcfdcb1084fdcaa922a1e5b30146a3b18 mozilla-build-arm.patch
+0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
+0cb16f394a3946a2bb31ef0084d8bbdc8e0e897d67c9224251d73fded07ab2fb193fcd8e5dd03109a3572a2455c44350b658cc64e2f981d047f45c8ade3afcf8 mozconfig"