summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-07-30 12:38:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-30 12:38:24 +0000
commit0615b6c0b127285338934ef4d7b874a65225174e (patch)
treec5216ae38cfd909b97554804e7d41524d3d30458
parenta367d15bffbabf1c4036ca2cf68bb3961786daad (diff)
downloadaports-0615b6c0b127285338934ef4d7b874a65225174e.tar.bz2
aports-0615b6c0b127285338934ef4d7b874a65225174e.tar.xz
main/lua-ossl: upgrade to 20140718
-rw-r--r--main/lua-ossl/APKBUILD12
-rw-r--r--main/lua-ossl/musl-fixes.patch20
2 files changed, 28 insertions, 4 deletions
diff --git a/main/lua-ossl/APKBUILD b/main/lua-ossl/APKBUILD
index d213b099c..6b46abe18 100644
--- a/main/lua-ossl/APKBUILD
+++ b/main/lua-ossl/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
pkgname=lua-ossl
-pkgver=20140328
+pkgver=20140718
_ver=${pkgver%_git*}
pkgrel=0
pkgdesc="comprehensive OpenSSL Lua module"
@@ -14,6 +14,7 @@ makedepends="$depends_dev lua5.2-dev openssl-dev"
install=""
subpackages=""
source="luaossl-$_ver.tar.gz::https://github.com/wahern/luaossl/archive/rel-$_ver.tar.gz
+ musl-fixes.patch
"
_builddir="$srcdir"/luaossl-rel-$_ver
@@ -39,6 +40,9 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="d7021b5748716af836b9e7671d833c68 luaossl-20140328.tar.gz"
-sha256sums="10f6a8f7232705d8291fa620ce36a5cc2d9c0d1ae3cb47bda1895e308de71fe8 luaossl-20140328.tar.gz"
-sha512sums="2c013f3b533d0bc703c3e69a48d0d08d4703c26d9433363f88fd937ff284743605973665ceb70a03f3c4d92c6c7066ac768e5ef2b086f74dc9f5102b090cf8e6 luaossl-20140328.tar.gz"
+md5sums="38d7c4527580e03335299349be4d70bc luaossl-20140718.tar.gz
+7d03f360ebc62b60279ff0f2066ed6f6 musl-fixes.patch"
+sha256sums="5711dc079ecb2c01b6a5eb753839efbb599ee92ce0bd971ea55fe696d0bb39e0 luaossl-20140718.tar.gz
+49694f9ab7f7a90074471d8e55580f13ff8fc6f7a158a5793f8d55df11147c0e musl-fixes.patch"
+sha512sums="5944ff745e08472e2be6b95c1fabdaaed46aeae8221d4e59fdbe8b8a4ee70368eb1d9cd39f619274a20151a46f5882445c89f69fc83cc54d812c01908ba1123d luaossl-20140718.tar.gz
+370467081c87c0e4b0c96a72ff81918d3d492dfa90578b34f51004461d9a983ffd486accb44471a34d092b1a08743ad60462c6937096f80f72a39a335ccd81be musl-fixes.patch"
diff --git a/main/lua-ossl/musl-fixes.patch b/main/lua-ossl/musl-fixes.patch
new file mode 100644
index 000000000..8b8c1c466
--- /dev/null
+++ b/main/lua-ossl/musl-fixes.patch
@@ -0,0 +1,20 @@
+--- ./src/openssl.c.orig
++++ ./src/openssl.c
+@@ -36,7 +36,7 @@
+ #include <errno.h> /* errno */
+
+ #include <sys/types.h> /* ssize_t pid_t */
+-#if !defined __sun && !defined _AIX
++#if defined __GLIBC__
+ #include <sys/sysctl.h> /* CTL_KERN KERN_RANDOM RANDOM_UUID KERN_URND KERN_ARND sysctl(2) */
+ #endif
+ #include <sys/time.h> /* struct timeval gettimeofday(2) */
+@@ -4609,7 +4609,7 @@
+
+
+ #ifndef HAVE_RANDOM_UUID
+-#define HAVE_RANDOM_UUID (defined __linux) /* RANDOM_UUID is an enum, not macro */
++#define HAVE_RANDOM_UUID (defined __GLIBC__) /* RANDOM_UUID is an enum, not macro */
+ #endif
+
+ #ifndef HAVE_KERN_URND