summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-07-31 06:00:53 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-07-31 06:00:53 +0000
commit94e964811fcc6d2d92189d6675061b5774188538 (patch)
tree0c062a7b5aef103f47d7a6f963366992aff1a967
parent5c06ee55aca0652f6a362b6441aeb4870d5b9212 (diff)
downloadaports-94e964811fcc6d2d92189d6675061b5774188538.tar.bz2
aports-94e964811fcc6d2d92189d6675061b5774188538.tar.xz
testing/py-larch: new aport
-rw-r--r--testing/py-larch/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py-larch/APKBUILD b/testing/py-larch/APKBUILD
new file mode 100644
index 000000000..4f07b5f83
--- /dev/null
+++ b/testing/py-larch/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=py-larch
+_pkgname=${pkgname#py-}
+pkgver=1.20131130
+pkgrel=0
+pkgdesc="Copy-on-write B-tree data structure"
+url="http://liw.fi/larch/"
+arch="noarch"
+license="GPL3+"
+depends="python py-tracing py-cliapp py-ttystatus"
+depends_dev=""
+makedepends="py-setuptools"
+install=""
+subpackages=""
+source="http://code.liw.fi/debian/pool/main/p/python-larch/python-larch_$pkgver.orig.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="766d14840b3872de92761a32ecbe80ef python-larch_1.20131130.orig.tar.gz"
+sha256sums="2717e851bde45b66e8b2d44181861f24135d185abab8111119857943d3b5cac1 python-larch_1.20131130.orig.tar.gz"
+sha512sums="e661fa29043a5254eb3615f0eb54f6afbaf59020607bb72f621083e9f6acfbe92b1c978ce2be73336d8984a4a64ce6d0153556f0af0ca63ad53aff40f785d052 python-larch_1.20131130.orig.tar.gz"