summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-15 21:30:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-15 21:30:56 +0000
commita022599e9baf42d233d386fd5c9a12f4c9cc971a (patch)
tree04924016d08d1a2c4c0debb923f292b6e079d998
parente62eb554b6ab8b056d5902c91ba6d6cc80997435 (diff)
downloadaports-a022599e9baf42d233d386fd5c9a12f4c9cc971a.tar.bz2
aports-a022599e9baf42d233d386fd5c9a12f4c9cc971a.tar.xz
x11/claws-mail: upgrade to 3.7.4
-rw-r--r--x11/claws-mail/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/x11/claws-mail/APKBUILD b/x11/claws-mail/APKBUILD
index 9a2f35851..5d133d744 100644
--- a/x11/claws-mail/APKBUILD
+++ b/x11/claws-mail/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=claws-mail
-pkgver=3.7.3
-pkgrel=4
+pkgver=3.7.4
+pkgrel=0
pkgdesc="A GTK+ based e-mail client."
url="http://www.claws-mail.org"
license="GPL3"
@@ -15,12 +15,14 @@ install= #claws-mail.install
source="http://downloads.sourceforge.net/sourceforge/sylpheed-claws/$pkgname-$pkgver.tar.bz2
libc-version.patch"
-
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
patch -p1 -i ../libc-version.patch || return 1
+}
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--disable-static \
--enable-enchant \
@@ -33,12 +35,16 @@ build ()
--enable-bogofilter-plugin \
--disable-jpilot
make || return 1
- make DESTDIR="$pkgdir" install
cd tools
make
- find -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i; do
- install -D -m755 ${i} "$pkgdir"/usr/lib/claws-mail/tools/${i}
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ find tools -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i; do
+ install -D -m755 ${i} "$pkgdir"/usr/lib/claws-mail/tools/${i}
done
}
-md5sums="b3af5ea5e1182aa53f971657db86e110 claws-mail-3.7.3.tar.bz2
+md5sums="aa6c8b9177bc2bc506470821ee2afbb2 claws-mail-3.7.4.tar.bz2
f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch"