summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-18 11:36:45 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-18 13:26:18 +0000
commitc870e4fc9291f6b19aae8953e7f2d7d3c665e3e9 (patch)
treea63e7117250e2f03241ed62d0a4334e3f110f4fa
parent09fa430d9efcf9152c8911f2109d9b22c1f655c4 (diff)
downloadaports-c870e4fc9291f6b19aae8953e7f2d7d3c665e3e9.tar.bz2
aports-c870e4fc9291f6b19aae8953e7f2d7d3c665e3e9.tar.xz
testing/tig: new aport
Tig is a git repository browser that additionally can act as a pager for output from various git commands. When browsing repositories, it uses the underlying git commands to present the user with various views, such as summarized revision log and showing the commit with the log message, diffstat, and the diff. http://jonas.nitro.dk/tig/
-rw-r--r--testing/tig/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/tig/APKBUILD b/testing/tig/APKBUILD
new file mode 100644
index 000000000..efb0b9c2f
--- /dev/null
+++ b/testing/tig/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=tig
+pkgver=1.0
+pkgrel=0
+pkgdesc="Text-mode interface for the git revision control system"
+url="http://jonas.nitro.dk/tig"
+arch="all"
+license="GPL2"
+depends="git"
+depends_dev=""
+makedepends="ncurses-dev xmlto asciidoc git"
+install=""
+subpackages="$pkgname-doc"
+source="http://jonas.nitro.dk/tig/releases/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make all doc-man || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install install-doc-man || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="a2d414d1cebbc9cd4f3d545bc6f225c6 tig-1.0.tar.gz"