summaryrefslogtreecommitdiffstats
path: root/main/acf-freeswitch-vmail
diff options
context:
space:
mode:
authorTed Trask <ttrask01@yahoo.com>2011-05-17 15:05:25 +0000
committerTed Trask <ttrask01@yahoo.com>2011-05-17 15:05:25 +0000
commit0038c58e264285009c7e1d3b0f8e396713882f5c (patch)
treefe213ec92f7be2feb5feb1fbf9989b6acf1bb208 /main/acf-freeswitch-vmail
parentb0a284c54a352bc7dd8e2b682b4f24ac5a4efee4 (diff)
downloadaports-0038c58e264285009c7e1d3b0f8e396713882f5c.tar.bz2
aports-0038c58e264285009c7e1d3b0f8e396713882f5c.tar.xz
main/acf-freeswitch-vmail: upgrade to 0.0.11
Diffstat (limited to 'main/acf-freeswitch-vmail')
-rw-r--r--main/acf-freeswitch-vmail/APKBUILD6
-rw-r--r--main/acf-freeswitch-vmail/acf-freeswitch-vmail.post-upgrade14
2 files changed, 17 insertions, 3 deletions
diff --git a/main/acf-freeswitch-vmail/APKBUILD b/main/acf-freeswitch-vmail/APKBUILD
index 29fc8c0d0..30199a2e7 100644
--- a/main/acf-freeswitch-vmail/APKBUILD
+++ b/main/acf-freeswitch-vmail/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ted Trask <ttrask01@yahoo.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-freeswitch-vmail
-pkgver=0.0.10
+pkgver=0.0.11
pkgrel=1
pkgdesc="ACF for a web interface for freeswitch voicemail"
url="http://git.alpinelinux.org/cgit/$pkgname"
@@ -9,7 +9,7 @@ arch="noarch"
license="GPL-2"
depends="acf-core lua lua-sql-sqlite3 freeswitch"
makedepends=""
-install=
+install="$pkgname.post-upgrade"
subpackages=""
source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2"
@@ -18,4 +18,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="7136328cd3d79e2b6087998067b0ca66 acf-freeswitch-vmail-0.0.10.tar.bz2"
+md5sums="4666f75fe85932a2848baa0511a431cc acf-freeswitch-vmail-0.0.11.tar.bz2"
diff --git a/main/acf-freeswitch-vmail/acf-freeswitch-vmail.post-upgrade b/main/acf-freeswitch-vmail/acf-freeswitch-vmail.post-upgrade
new file mode 100644
index 000000000..3b0ff119c
--- /dev/null
+++ b/main/acf-freeswitch-vmail/acf-freeswitch-vmail.post-upgrade
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+new=$1
+old=$2
+
+# if current is not older than 0.0.11 we exit.
+if ! [ "$(apk version -t $old 0.0.11)" = "<" ]; then
+ exit 0
+fi
+
+sqlite3 /var/lib/freeswitch/db/voicemail_default.db "UPDATE voicemail_params SET descr='Passwords must be all numbers and at least three digits' WHERE name='vm-password'"
+
+exit 0
+