summaryrefslogtreecommitdiffstats
path: root/main/asterisk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-15 09:46:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-15 09:46:06 +0000
commit0ce04fbb43bc5b0146f29c4fe3e3e9bf5589b702 (patch)
tree0c7efc777bb2b0a1371de62c85fa3d3d1d643b0f /main/asterisk
parent534de6ee51a1d5b9cfe9456b9068c2b2fc946257 (diff)
downloadaports-0ce04fbb43bc5b0146f29c4fe3e3e9bf5589b702.tar.bz2
aports-0ce04fbb43bc5b0146f29c4fe3e3e9bf5589b702.tar.xz
main/asterisk: build fix, force ldconfig flags
the makefile checks for linux-gnu to detect flag for ldconfig to only process given dirs. We set it hard since it fails to do the right thing on uclibc.
Diffstat (limited to 'main/asterisk')
-rw-r--r--main/asterisk/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index a31ac58c3..327f9878c 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -90,12 +90,12 @@ build() {
make menuselect.makeopts
# enable chan_mobile
sed -i -e '/^MENUSELECT_ADDONS=/s/chan_mobile//' menuselect.makeopts
- make ASTCFLAGS="$CFLAGS" ASTLDFLAGS="$LDFLAGS" || return 1
+ make ASTCFLAGS="$CFLAGS" ASTLDFLAGS="$LDFLAGS" LDCONFIG_FLAGS="-n" || return 1
}
package() {
cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install
+ make -j1 DESTDIR="$pkgdir" LDCONFIG_FLAGS="-n" install
install -d "$pkgdir"/var/run/asterisk
install -d "$pkgdir"/var/lib/asterisk