summaryrefslogtreecommitdiffstats
path: root/main/audacious-plugins
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-26 08:40:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-26 08:43:06 +0000
commitd3dd4a4d486766bf565f73bd9410d265fd9de693 (patch)
tree8dbf3ee5cb0b2524b9ab2d67a5e02885a7540c46 /main/audacious-plugins
parentd1d4e41d680c09f00e12996336f096c8b1548ef8 (diff)
downloadaports-d3dd4a4d486766bf565f73bd9410d265fd9de693.tar.bz2
aports-d3dd4a4d486766bf565f73bd9410d265fd9de693.tar.xz
main/audacious-plugins: upgrade to 3.2.2
Diffstat (limited to 'main/audacious-plugins')
-rw-r--r--main/audacious-plugins/APKBUILD17
-rw-r--r--main/audacious-plugins/audacious-plugins-3.2.2-fix-build-gmodule.patch31
2 files changed, 41 insertions, 7 deletions
diff --git a/main/audacious-plugins/APKBUILD b/main/audacious-plugins/APKBUILD
index 80ed9052f..d1fc5f7c5 100644
--- a/main/audacious-plugins/APKBUILD
+++ b/main/audacious-plugins/APKBUILD
@@ -1,14 +1,13 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=audacious-plugins
-pkgver=3.2
-pkgrel=2
+pkgver=3.2.2
+pkgrel=0
pkgdesc="playlist-oriented media player with multiple interfaces (plugins)"
url="http://audacious-media-player.org/"
arch="all"
license="ISC"
depends=audacious
-subpackages="$pkgname-lang"
install_if=audacious
_want_ffmpeg="ffmpeg-dev"
makedepends="libmowgli-dev
@@ -44,11 +43,14 @@ makedepends="libmowgli-dev
wavpack-dev
lame-dev
flac-dev
+ sdl-dev
+ automake
autoconf"
install=
-subpackages=
-source="http://distfiles.audacious-media-player.org/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-lang"
+source="http://distfiles.audacious-media-player.org/$pkgname-$pkgver.tar.gz
+ audacious-plugins-3.2.2-fix-build-gmodule.patch"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -65,7 +67,7 @@ prepare() {
done
msg "Rebuilding configure..."
- autoconf
+ aclocal -I m4 && autoheader && autoconf || return 1
# workaround bug in busybox
sed -e "/touch/s/0001010000/200001010000/g" \
@@ -87,4 +89,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="34a8ccaf720b93dba7f2c00f544b5d0a audacious-plugins-3.2.tar.gz"
+md5sums="a64657173cca404a8f0df51962fee287 audacious-plugins-3.2.2.tar.gz
+1d29a9e4a5e58b5ece4538f30d027279 audacious-plugins-3.2.2-fix-build-gmodule.patch"
diff --git a/main/audacious-plugins/audacious-plugins-3.2.2-fix-build-gmodule.patch b/main/audacious-plugins/audacious-plugins-3.2.2-fix-build-gmodule.patch
new file mode 100644
index 000000000..2f06396e8
--- /dev/null
+++ b/main/audacious-plugins/audacious-plugins-3.2.2-fix-build-gmodule.patch
@@ -0,0 +1,31 @@
+commit a29df1ab4ba9f3964ca475c0c727136357ddfb86
+Author: John Lindgren <john.lindgren@aol.com>
+Date: Mon Apr 2 02:10:32 2012 -0400
+
+ Make check for GMODULE_{CFLAGS,LIBS} unconditional; LADSPA plugin needs it also.
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 6f6f293..5acb6b7 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -194,6 +194,7 @@ AC_PATH_PROG([WINDRES], [windres])
+ dnl Check for Gtk+/GLib and pals
+ dnl ============================
+ AUD_CHECK_MODULE([GLIB], [glib-2.0], [>= 2.16], [Glib2])
++AUD_CHECK_MODULE([GMODULE], [gmodule-2.0], [>= 2.16], [GModule])
+ AUD_CHECK_MODULE([GTHREAD], [gthread-2.0], [>= 2.16], [GThread])
+ AUD_CHECK_MODULE([PANGO], [pango], [>= 1.20], [Pango])
+ AUD_CHECK_MODULE([CAIRO], [cairo], [>= 1.6], [Cairo])
+diff --git a/configure.ac b/configure.ac
+index d976576..358f841 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -757,8 +757,6 @@ fi
+
+ if test "x$enable_amidiplug" = "xyes"; then
+ INPUT_PLUGINS="$INPUT_PLUGINS amidi-plug"
+- PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.6.0],,)
+- PKG_CHECK_MODULES(GMODULE, [gmodule-2.0 >= 2.6.0],,)
+ AMIDIPLUG_BACKEND_DIR=amidi-plug
+ AC_SUBST(AMIDIPLUG_BACKEND_DIR)
+ if test "x$enable_amidiplug_alsa" = "xauto" -o "x$enable_amidiplug_alsa" = "xyes"; then