summaryrefslogtreecommitdiffstats
path: root/main/bsm-simple-themes
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-06 09:07:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-06 09:07:35 +0000
commit7d11a1d0bdfa4e6677ff3e92fb92b6fb5deabd4d (patch)
tree4230c9dd3dc1a12ffd12852eec11271e51b35ec2 /main/bsm-simple-themes
parent4d07a0e655f6e006e06981fc7bd06c45f170422e (diff)
downloadaports-7d11a1d0bdfa4e6677ff3e92fb92b6fb5deabd4d.tar.bz2
aports-7d11a1d0bdfa4e6677ff3e92fb92b6fb5deabd4d.tar.xz
main/bsm-simple-themes: moved from testing
Diffstat (limited to 'main/bsm-simple-themes')
-rw-r--r--main/bsm-simple-themes/APKBUILD74
-rw-r--r--main/bsm-simple-themes/bsm-simple-panel.patch60
-rw-r--r--main/bsm-simple-themes/bsm-simple-xfwm.patch218
3 files changed, 352 insertions, 0 deletions
diff --git a/main/bsm-simple-themes/APKBUILD b/main/bsm-simple-themes/APKBUILD
new file mode 100644
index 000000000..8c85fa14b
--- /dev/null
+++ b/main/bsm-simple-themes/APKBUILD
@@ -0,0 +1,74 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bsm-simple-themes
+pkgver=1.3
+_ver=${pkgver/./}
+pkgrel=2
+pkgdesc="BSM Simple GTK Themes"
+url="http://gnome-look.org/content/show.php/?content=121685"
+arch="noarch"
+license="GPL"
+depends="gtk-engines-clearlooks faenza-icon-theme"
+makedepends=""
+install=""
+subpackages="$pkgname-xfwm4 $pkgname-metacity"
+source="http://gnome-look.org/CONTENT/content-files/121685-BSM%20Simple%20$_ver.tar.gz
+ bsm-simple-panel.patch
+ bsm-simple-xfwm.patch"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ # fix permissions
+ find . -type d -exec chmod 755 '{}' \;
+ find . -type f -exec chmod 644 '{}' \;
+ mkdir -p "$pkgdir"/usr/share/themes
+ for i in *; do
+ [ -L "$i" ] && continue
+ cp -ra "$i" "$pkgdir"/usr/share/themes/ || return 1
+ done
+}
+
+xfwm4() {
+ pkgdesc="BSM Simple GTK Themes - xfwm4"
+ install_if="$pkgname=$pkgver-r$pkgrel xfwm4"
+ cd "$pkgdir"
+ find -name 'xfwm4' -type d | while read dir; do
+ mkdir -p "$subpkgdir/${dir%/*}"
+ mv "$dir" "$subpkgdir/${dir%*}"
+ done
+}
+
+metacity() {
+ pkgdesc="BSM Simple GTK Themes - metacity"
+ install_if="$pkgname=$pkgver-r$pkgrel metacity"
+ cd "$pkgdir"
+ find -name 'metacity-?' -type d | while read dir; do
+ mkdir -p "$subpkgdir/${dir%/*}"
+ mv "$dir" "$subpkgdir/${dir%*}"
+ done
+}
+
+md5sums="26ba7fd532b8811e77a041ce8bacf79f 121685-BSM%20Simple%2013.tar.gz
+397bb9e05136048d64f5c4e629434245 bsm-simple-panel.patch
+ae6887234cee7e18330f6f2fc79b65be bsm-simple-xfwm.patch"
+sha256sums="c38466dc422ed58518001f4b8f7b5e5adb124e7180e6815604592556d18d2ab0 121685-BSM%20Simple%2013.tar.gz
+9ea99e560aac8535be06da6d3382101f88652a8e990e38547f96f814118194e3 bsm-simple-panel.patch
+5d7c326267e64bb4f9e15a8c72025543780dd70026c91b54b082d98bfd876a0b bsm-simple-xfwm.patch"
+sha512sums="4254ccdb2869a1caefbac9f9b1bffa6f5bc0a3ba64989d198cd2154d23e5e725dd8f408b17bb37d56eaef6ce74660d29b1167d99b91df7480ddf649957449adb 121685-BSM%20Simple%2013.tar.gz
+84ad713a7a5850b970a96e97d6c71b81e127a02caead429b71cd50868bfdfce6d327ed113aca40f7a4d4ccfd18f48a84ec27dcbc2af6fe0cbbb47e207ad41e47 bsm-simple-panel.patch
+8f015a39d06d6713d75d872fba1139cf734a7ea6af272e198cbc0192148c5eabed3828902a608aa83b2661fc92159057508a9e792f7032680c6f728325b6792f bsm-simple-xfwm.patch"
diff --git a/main/bsm-simple-themes/bsm-simple-panel.patch b/main/bsm-simple-themes/bsm-simple-panel.patch
new file mode 100644
index 000000000..4376a119a
--- /dev/null
+++ b/main/bsm-simple-themes/bsm-simple-panel.patch
@@ -0,0 +1,60 @@
+diff --git a/BSM Simple Dark Menu/gtk-2.0/panel.rc b/BSM Simple Dark Menu/gtk-2.0/panel.rc
+index f0ab2bf..639754f 100755
+--- a/BSM Simple Dark Menu/gtk-2.0/panel.rc
++++ b/BSM Simple Dark Menu/gtk-2.0/panel.rc
+@@ -27,8 +27,8 @@ style "theme-panel"
+
+ style "theme-panel2" = "theme-panel"
+ {
+-xthickness = 0
+-ythickness = 0
++xthickness = 2
++ythickness = 1
+ engine "clearlooks"{
+ radius = 1.1
+ }
+diff --git a/BSM Simple Dark Panel/gtk-2.0/panel.rc b/BSM Simple Dark Panel/gtk-2.0/panel.rc
+index f5dac43..3c16d7a 100755
+--- a/BSM Simple Dark Panel/gtk-2.0/panel.rc
++++ b/BSM Simple Dark Panel/gtk-2.0/panel.rc
+@@ -27,8 +27,8 @@ style "theme-panel"
+
+ style "theme-panel2" = "theme-panel"
+ {
+-xthickness = 0
+-ythickness = 0
++xthickness = 2
++ythickness = 1
+ engine "clearlooks"{
+ radius = 1.1
+ }
+diff --git a/BSM Simple Dark/gtk-2.0/panel.rc b/BSM Simple Dark/gtk-2.0/panel.rc
+index 2f6298e..2cc579e 100755
+--- a/BSM Simple Dark/gtk-2.0/panel.rc
++++ b/BSM Simple Dark/gtk-2.0/panel.rc
+@@ -22,8 +22,8 @@ style "theme-panel"
+
+ style "theme-panel2" = "theme-panel"
+ {
+-xthickness = 0
+-ythickness = 0
++xthickness = 2
++ythickness = 1
+ engine "clearlooks"{
+ radius = 1.1
+ }
+diff --git a/BSM Simple/gtk-2.0/panel.rc b/BSM Simple/gtk-2.0/panel.rc
+index d2e51f3..72fbeaa 100755
+--- a/BSM Simple/gtk-2.0/panel.rc
++++ b/BSM Simple/gtk-2.0/panel.rc
+@@ -14,8 +14,8 @@ style "theme-panel"
+
+ style "theme-panel2" = "theme-panel"
+ {
+-xthickness = 0
+-ythickness = 0
++xthickness = 2
++ythickness = 1
+ engine "clearlooks"{
+ radius = 1.1
+ }
diff --git a/main/bsm-simple-themes/bsm-simple-xfwm.patch b/main/bsm-simple-themes/bsm-simple-xfwm.patch
new file mode 100644
index 000000000..672e5c1c9
--- /dev/null
+++ b/main/bsm-simple-themes/bsm-simple-xfwm.patch
@@ -0,0 +1,218 @@
+diff --git a/BSM Simple/xfwm4/bottom-active.xpm b/BSM Simple/xfwm4/bottom-active.xpm
+index 4096e85..49d4eab 100644
+--- a/BSM Simple/xfwm4/bottom-active.xpm
++++ b/BSM Simple/xfwm4/bottom-active.xpm
+@@ -1,6 +1,10 @@
+ /* XPM */
+ static char * bottom_active_xpm[] = {
+-"17 1 2 1",
++"16 3 4 1",
+ " c None",
+ ". c #888888",
+-"................."};
++"o c #C0C0C0",
++"0 c #d0d0d0",
++"0000000000000000",
++"oooooooooooooooo",
++"................"};
+diff --git a/BSM Simple/xfwm4/bottom-inactive.xpm b/BSM Simple/xfwm4/bottom-inactive.xpm
+index fbfbe7b..2ebcdd5 100644
+--- a/BSM Simple/xfwm4/bottom-inactive.xpm
++++ b/BSM Simple/xfwm4/bottom-inactive.xpm
+@@ -1,6 +1,10 @@
+ /* XPM */
+ static char * bottom_inactive_xpm[] = {
+-"17 1 2 1",
++"16 3 4 1",
+ " c None",
+ ". c #888888",
+-"................."};
++"o c #C0C0C0",
++"0 c #d0d0d0",
++"0000000000000000",
++"oooooooooooooooo",
++"................"};
+diff --git a/BSM Simple/xfwm4/bottom-left-active.xpm b/BSM Simple/xfwm4/bottom-left-active.xpm
+index 5bd7b94..b5a975b 100644
+--- a/BSM Simple/xfwm4/bottom-left-active.xpm
++++ b/BSM Simple/xfwm4/bottom-left-active.xpm
+@@ -1,22 +1,23 @@
+ /* XPM */
+ static char * bottom_left_active_xpm[] = {
+-"1 17 2 1",
++"16 16 4 1",
+ " c None",
+ ". c #888888",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-"."};
++"o c #C0C0C0",
++"0 c #d0d0d0",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++".000000000000000",
++".ooooooooooooooo",
++" ..............."};
+diff --git a/BSM Simple/xfwm4/bottom-left-inactive.xpm b/BSM Simple/xfwm4/bottom-left-inactive.xpm
+index cbd3b99..1a03ca7 100644
+--- a/BSM Simple/xfwm4/bottom-left-inactive.xpm
++++ b/BSM Simple/xfwm4/bottom-left-inactive.xpm
+@@ -1,22 +1,23 @@
+ /* XPM */
+ static char * bottom_left_inactive_xpm[] = {
+-"1 17 2 1",
++"16 16 4 1",
+ " c None",
+ ". c #888888",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-"."};
++"o c #C0C0C0",
++"0 c #d0d0d0",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++". ",
++".000000000000000",
++".ooooooooooooooo",
++" ..............."};
+diff --git a/BSM Simple/xfwm4/bottom-right-active.xpm b/BSM Simple/xfwm4/bottom-right-active.xpm
+index fb3039f..6b16404 100644
+--- a/BSM Simple/xfwm4/bottom-right-active.xpm
++++ b/BSM Simple/xfwm4/bottom-right-active.xpm
+@@ -1,22 +1,23 @@
+ /* XPM */
+ static char * bottom_right_active_xpm[] = {
+-"1 17 2 1",
++"16 16 4 1",
+ " c None",
+ ". c #888888",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-"."};
++"o c #C0C0C0",
++"0 c #d0d0d0",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++"000000000000000.",
++"ooooooooooooooo.",
++"............... "};
+diff --git a/BSM Simple/xfwm4/bottom-right-inactive.xpm b/BSM Simple/xfwm4/bottom-right-inactive.xpm
+index 527219a..002cc24 100644
+--- a/BSM Simple/xfwm4/bottom-right-inactive.xpm
++++ b/BSM Simple/xfwm4/bottom-right-inactive.xpm
+@@ -1,22 +1,23 @@
+ /* XPM */
+ static char * bottom_right_inactive_xpm[] = {
+-"1 17 2 1",
++"16 16 4 1",
+ " c None",
+ ". c #888888",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-".",
+-"."};
++"o c #C0C0C0",
++"0 c #d0d0d0",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++" .",
++"000000000000000.",
++"ooooooooooooooo.",
++"............... "};