summaryrefslogtreecommitdiffstats
path: root/main/bsnes
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-25 16:51:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-25 18:54:07 +0000
commitb5c0890914ac3debe6d569fdcd25c88d57ea6865 (patch)
tree1c0e2cc1787da1923dc6e2c88df938df135cec64 /main/bsnes
parentfb1ef2c33ecb16bc986503dd88414f8433bbe98d (diff)
downloadaports-b5c0890914ac3debe6d569fdcd25c88d57ea6865.tar.bz2
aports-b5c0890914ac3debe6d569fdcd25c88d57ea6865.tar.xz
main/bsnes: upgrade to 0.83
Diffstat (limited to 'main/bsnes')
-rw-r--r--main/bsnes/APKBUILD6
-rw-r--r--main/bsnes/nall-strlcpy.patch44
2 files changed, 25 insertions, 25 deletions
diff --git a/main/bsnes/APKBUILD b/main/bsnes/APKBUILD
index 7b4e8121f..0916f07e7 100644
--- a/main/bsnes/APKBUILD
+++ b/main/bsnes/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=bsnes
-pkgver=0.78
+pkgver=0.83
_x=${pkgver%.*}
_y=${pkgver#*.}
_pkgver="v${_x}${_y}"
@@ -40,6 +40,6 @@ package() {
make DESTDIR="$pkgdir" prefix=/usr profile=performance install || return 1
}
-md5sums="19c07dc9be18bf3314f4e7122c00f16e bsnes_v078-source.tar.bz2
-d5017142f2cbccac878bbfc799b3445f nall-strlcpy.patch
+md5sums="a1f017f5276ec5be0bc553db2b7e2241 bsnes_v083-source.tar.bz2
+11d7129c769add65a4b03ef9193729f2 nall-strlcpy.patch
07caea846bf49ee6f5deaf999dffbd5f no-pulseaudio.patch"
diff --git a/main/bsnes/nall-strlcpy.patch b/main/bsnes/nall-strlcpy.patch
index dd4a005a6..fa0859d44 100644
--- a/main/bsnes/nall-strlcpy.patch
+++ b/main/bsnes/nall-strlcpy.patch
@@ -1,31 +1,31 @@
---- bsnes_v077-source/bsnes/snes/system/serialization.cpp
-+++ bsnes_v077-source/bsnes/snes/system/serialization.cpp
-@@ -7,7 +7,7 @@
- char profile[16], description[512];
- memset(&profile, 0, sizeof profile);
- memset(&description, 0, sizeof description);
-- strlcpy(profile, Info::Profile, sizeof profile);
-+ nall::strlcpy(profile, Info::Profile, sizeof profile);
-
- s.integer(signature);
- s.integer(version);
---- bsnes_v077-source/bsnes/ui/tools/state-manager.cpp
-+++ bsnes_v077-source/bsnes/ui/tools/state-manager.cpp
-@@ -130,7 +130,7 @@
- string StateManager::slotLoadDescription(unsigned i) {
- if(slot[i].capacity() == 0) return "(empty)";
- char text[512];
-- strlcpy(text, (const char*)slot[i].data() + HeaderLength, 512);
-+ nall::strlcpy(text, (const char*)slot[i].data() + HeaderLength, 512);
+--- ./bsnes/ui/tools/state-manager.cpp.orig
++++ ./bsnes/ui/tools/state-manager.cpp
+@@ -135,7 +135,7 @@
+ string StateManager::slotLoadDescription(unsigned n) {
+ if(slot[n].capacity() == 0) return "(empty)";
+ char text[DescriptionLength];
+- strlcpy(text, (const char*)slot[n].data() + HeaderLength, DescriptionLength);
++ nall::strlcpy(text, (const char*)slot[n].data() + HeaderLength, DescriptionLength);
return text;
}
-@@ -138,7 +138,7 @@
+@@ -143,7 +143,7 @@
if(stateList.selected() == false) return;
string text = descEdit.text();
if(slot[stateList.selection()].capacity() > 0) {
-- strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, 512);
-+ nall::strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, 512);
+- strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, DescriptionLength);
++ nall::strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, DescriptionLength);
}
refresh();
}
+--- ./bsnes/snes/system/serialization.cpp.orig
++++ ./bsnes/snes/system/serialization.cpp
+@@ -7,7 +7,7 @@
+ char description[512], profile[16];
+ memset(&description, 0, sizeof description);
+ memset(&profile, 0, sizeof profile);
+- strlcpy(profile, Info::Profile, sizeof profile);
++ nall::strlcpy(profile, Info::Profile, sizeof profile);
+
+ s.integer(signature);
+ s.integer(version);