summaryrefslogtreecommitdiffstats
path: root/main/dovecot
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-19 09:17:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-19 09:17:38 +0000
commitf67f0e7b5a55de967e9a9a50e5ab2f6d20f24650 (patch)
treee6d442177c77c7a705b8ec3e898d0e3d8c4d1bca /main/dovecot
parenteccb1fba3c1d1104bbe9b1cbf2d1356769b8fe9d (diff)
downloadaports-f67f0e7b5a55de967e9a9a50e5ab2f6d20f24650.tar.bz2
aports-f67f0e7b5a55de967e9a9a50e5ab2f6d20f24650.tar.xz
main/dovecot: replace opts in init.d script
ref #943
Diffstat (limited to 'main/dovecot')
-rw-r--r--main/dovecot/APKBUILD4
-rw-r--r--main/dovecot/dovecot.initd10
2 files changed, 7 insertions, 7 deletions
diff --git a/main/dovecot/APKBUILD b/main/dovecot/APKBUILD
index 7fc28308c..55ee908f9 100644
--- a/main/dovecot/APKBUILD
+++ b/main/dovecot/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dovecot
pkgver=2.0.17
-pkgrel=0
+pkgrel=1
pkgdesc="IMAP and POP3 server"
url="http://www.dovecot.org/"
arch="all"
@@ -118,5 +118,5 @@ config() {
md5sums="41c10dffa56e228b9176833db2efaac5 dovecot-2.0.17.tar.gz
aec5cc797ab2acf72ce3b6bb1030345f dovecot.logrotate
-01067b40dfd74dfb79b946af1e680745 dovecot.initd
+59f210c712284a82e3a65b4126ddd99c dovecot.initd
95cf57ecc835882228bbbb019ce3abf8 dovecot-sample-config.post-install"
diff --git a/main/dovecot/dovecot.initd b/main/dovecot/dovecot.initd
index 8e2075d5a..b9ef27578 100644
--- a/main/dovecot/dovecot.initd
+++ b/main/dovecot/dovecot.initd
@@ -1,9 +1,9 @@
#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/files/dovecot.init-r2,v 1.3 2010/05/19 13:26:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/files/dovecot.init-r3,v 1.1 2011/09/17 10:33:38 eras Exp $
-opts="${opts} reload"
+extra_started_commands="reload"
depend() {
need localmount net
@@ -53,7 +53,7 @@ stop() {
reload() {
checkconfig || return 1
ebegin "Reloading ${SVCNAME} configs and restarting auth/login processes"
- start-stop-daemon --stop --oknodo --exec /usr/sbin/dovecot \
- --pidfile "${DOVECOT_PIDFILE}" --signal HUP
+ start-stop-daemon --signal HUP --exec /usr/sbin/dovecot \
+ --pidfile "${DOVECOT_PIDFILE}"
eend $?
}