summaryrefslogtreecommitdiffstats
path: root/main/e2fsprogs
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 17:29:05 +0300
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 17:29:49 +0300
commitc5d8cfdc4a5a1b5303475627fd265422dc1887df (patch)
tree6f5098c21759d27a970cbe23a92fe5c20e345da0 /main/e2fsprogs
parent1751d6595597f1d9101cac04e54f20d95790f4f4 (diff)
downloadaports-c5d8cfdc4a5a1b5303475627fd265422dc1887df.tar.bz2
aports-c5d8cfdc4a5a1b5303475627fd265422dc1887df.tar.xz
main/e2fsprogs: fix build on uclibc
also include stdint.h to get the standard types
Diffstat (limited to 'main/e2fsprogs')
-rw-r--r--main/e2fsprogs/APKBUILD6
-rw-r--r--main/e2fsprogs/fix_uint64_t.patch15
2 files changed, 15 insertions, 6 deletions
diff --git a/main/e2fsprogs/APKBUILD b/main/e2fsprogs/APKBUILD
index 71273a3c6..d494f77f7 100644
--- a/main/e2fsprogs/APKBUILD
+++ b/main/e2fsprogs/APKBUILD
@@ -57,8 +57,8 @@ libcom_err() {
}
md5sums="8ef664b6eb698aa6b733df59b17b9ed4 e2fsprogs-1.42.8.tar.gz
-2c1d4c967eaadd29a4caa10d34004fb9 fix_uint64_t.patch"
+64cc1406a634a16b6e411a49e67715e9 fix_uint64_t.patch"
sha256sums="b984aaf1fe888d6a4cf8c2e8d397207879599b5368f1d33232c1ec9d68d00c97 e2fsprogs-1.42.8.tar.gz
-b08907df2c226aba25b46a0f945eaf1c980bdb8d1ed729ae43eaae9b1d37fa91 fix_uint64_t.patch"
+4ad117a5bbd9d134b0e65b89094c3efe276c3a3456f45bd7842dd046803ec861 fix_uint64_t.patch"
sha512sums="69447105cbfec6099a8b7686d7cb8f4727d8c7c3f438acd0ec065ece70c225ce2c5e72e22ba16d88ef6dac81112b7571083d0cadd2fd1c82415c959ae632e61c e2fsprogs-1.42.8.tar.gz
-2b9895d604c193098587b323e957f1d454b5c6963b10afb61054822736c22517ce2660b2eeb0b6b6b09d95caf11cc5b100af3e26d3713c5e6891a09305b1967f fix_uint64_t.patch"
+b8645d1d83527f1ddd8a59b8a3f4658b226d76fc381fde6f38f77d3866038541a237d3a31ced657ad9950c798da299b33cdf55b138f71ab352d62969d9b995ae fix_uint64_t.patch"
diff --git a/main/e2fsprogs/fix_uint64_t.patch b/main/e2fsprogs/fix_uint64_t.patch
index 8433e11ab..0d26f4fa5 100644
--- a/main/e2fsprogs/fix_uint64_t.patch
+++ b/main/e2fsprogs/fix_uint64_t.patch
@@ -1,6 +1,15 @@
---- e2fsprogs-1.42.8.orig/lib/ext2fs/unix_io.c
-+++ e2fsprogs-1.42.8/lib/ext2fs/unix_io.c
-@@ -931,10 +931,10 @@
+diff -ru e2fsprogs-1.42.8.orig/lib/ext2fs/unix_io.c e2fsprogs-1.42.8/lib/ext2fs/unix_io.c
+--- e2fsprogs-1.42.8.orig/lib/ext2fs/unix_io.c 2013-09-27 17:26:55.203155268 +0300
++++ e2fsprogs-1.42.8/lib/ext2fs/unix_io.c 2013-09-27 17:27:27.782978767 +0300
+@@ -23,6 +23,7 @@
+
+ #include "config.h"
+ #include <stdio.h>
++#include <stdint.h>
+ #include <string.h>
+ #if HAVE_UNISTD_H
+ #include <unistd.h>
+@@ -931,10 +932,10 @@
if (channel->flags & CHANNEL_FLAGS_BLOCK_DEVICE) {
#ifdef BLKDISCARD